Facebook "Domain Verification Failed"

I’m out of ideas so reaching out: Cloudflare DNS, Squarespace website.

Using Facebook Business Settings → Brand Safety-> Domains

Have entered the TXT record as FB require. FB definitely read it - I get different errors if I put the record in quotes, or delete the facebook-domain-verification tag.

I’ve tried removing and re-adding the domain name in FB - so they provide a different code.

The TXT record looks fine using TXT Lookup Online, View DNS TXT (Text) Records | IPVoid

I’d welcome any fresh ideas!

If your domain is added to your Cloudflare account and having the nameservers of Cloudflare.
Also, if the A yourdomain.com and A www records at Cloudflare DNS dashboard are being :orange: cloud (proxied via Cloudflare).
Moreover, if you added an TXT record with @ symbol and in the content you have copied the value given from Facebook Business → Domains, it should be correctly added in a few minutes or less.

Maybe you are running some Firewall Rules or other security options to protect your Website which could potentially block Facebook bot that checks for that TXT record?

Have you done it this way as step-by-step instructions for a TXT record in the article below?:

It should look like this one at the DNS tab of your Cloudflare dashboard from when adding new one:

And this like when you check if you have one (using www instead of @ for example):

Thanks for the fast response. I think I have it right.

The @ converts to yourdomain.com when I hit save, which I assume is correct.

The result looks OK if I request the TXT records using a 3rd party tool

yourdomain.com. 299 IN TXT “facebook-domain-verification=78kkumxdsf3iynqx81m5b97nbeq7il”

Also, FB detect if I change the code, and return a Mismatch error. That would seem to preclude the Firewall Rule problem too.

I’m not sure the proxied/DNS setting makes a difference. Squarespace complained about the proxied but I’ve put that back for now anyway.

I’m trying to get through to Facebook support, but appreciate your suggestions.

1 Like

Exactly, yes.

Maybe you put an old code, or a new one and tries to check one or maybe both of them?
You can keep both of them just in case until the domain verification is successfull.

If the records are :grey:, the added TXT records at your domain seems to me it would have the same effect as you actually weren’t added them at first place, due to the A www or A yourdomain.com record is :grey: (not proxied), so I guess the Facebook tool would go to your hosting DNS and ignore the Cloudflare’s DNS records.

Maybe I am wrong about this one.

Due to Squarespace, does it mean you have got an CNAME record at your Cloudflare dashboard?

Have you followed this article how to setup Squarespace with Cloudflare (depending where your domain is registered?):

In case if you cannot get it working with a DNS-only setup (:grey: cloud only records), then there is no way to get it work via proxy (:orange: cloud records).

Is there some other way to verify your domain? (DNS, HTML upload, Meta tags)
Have you tried some other maybe?

Once again - thanks.

I think this must be a FB problem. I also tried using the meta tag method, and again, if I deliberately change the code by one letter, I get this response from FB:

image

If I use the correct code I get “Unable to verify domain” again.

It seems to me this indicates FB are reading and checking that record, and agree that it matches. So it is some other problem.

I finally got hold of FB support and they promised to look into it.

48 hours later the domain magically verified. I hope they will tell me what they changed - but it appears the problem was their end.

Thanks for all the suggestions.

1 Like

May I ask if you contacted their support or via Live chat somehow?

Great! It could be some internal issue at Facebook.

I am happy to assist you and glad you found a solution to your issue :wink:

1 Like