Extremely High TTFB Wordpress + Gcloud + Cloudflare

Getting an extremely high TTFB of 15.2 secs on our website www.thealtmart.in which is a Wordpress website using Woocommerce.

My origin server is hosted on Cent OS 7 VPS on Google Cloud Mumbai, India.

Server Specs:
4GB RAM - Quad Core CPU running a LAMP Stack.

The origin server has a TTFB of 210 ms (IP: 34.93.166.136) where as the Domain www.thealtmart.in has an extremely high TTFB value, that eliminates any issue from Google Cloud end.

These are some of the things i’v already tried but in vain.

  1. There are no CPU spikes while using the site
  2. Running minimum plugins for the functionality requirements we have.
  3. Running Automoptimize Cache plugin and CDN for compressed images
  4. Have implemented all the suggestions Google Page Insights has given
  5. Minify HTML/CSS, Defer JS implemented.
  6. Page size is less than 3 MB in total.

Kindly help me with this.

Thanks !

That’s quite excessive. I’m getting ~3 second TTFB in Los Angeles, but global tests show closer to the 15 seconds. Only Frankfort matches what I’m seeing. So that doesn’t make sense to me.
https://tools.keycdn.com/performance?url=https://www.thealtmart.in/

If you put the site in Development Mode, does it change TTFB?

I know it’s not fair to have to pay for lower latency, but I’d try enabling Argo to see if it helps. It would be $5 to enable just to test, then turn it off it it doesn’t help.

First, you may want to contact Support to ask about the discrepancy in performance at different locations. Again, in Los Angeles and Frankfort, it’s ~3 seconds. Everywhere else, it’s ~15 seconds.

Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button.

Hi Thank you for reply ! Yes the TTFB goes down to 1-2secs avg once i put the site to Development Mode, attaching screenshot of the tests. What might be the issue while turning on Cloudflare CDN & Cache ?

I don’t recall if you had Rocket Loader enabled, but it could be causing the delay if it’s trying to gather all your JS before sending that first byte. Try disabling Rocket Loader in the Speed -> Optimization settings page.

If that doesn’t do it, then create a Page Rule to match www.thealtmart.in/* and then start adding a settings to disable Cloudflare features until you find out which feature is slowing the site down.

1 Like

I think the above mentioned website is using excessive facebook scripts/plugin which is causing the slowdown (I noticed more than 40 javascript from facebook).

plus cache setting might not be appropriate at CF level.

cf-cache-status : REVALIDATED

I agree it’s a ton of scripts (56 alone from your domain), but Rocket Loader looks to account for the high TTFB. Facebook certainly isn’t helping adds another 30 or so, but that doesn’t impact TTFB.

In place or Rocket Loader, try using the Autoptimize plugin to speed up JS (and CSS).

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.