Extreme performance drop on HTTPS

I have the following problem. My site has been on Cloudflare for several months. Everything ran without problems from the beginning. Nothing was changed neither on Cloudflare nor on the server. Since yesterday there are extreme performance problems with https. Everything was checked on the server. The server was also restarted but without success. On the server IPERF and speed tests were made a network problem on server side can be excluded.

How does the problem manifest itself
As soon as the access is done via HTTPS (via Cloudflare) the speed is extremely bad. Here is a small example:

A Wget download over HTTPS reduces the speed to a few kilobytes/s.

Here is a Print Screen

The Same download directly without https from the server goes fullspeed (Sorry as new user i can only attach one Printscreen for the moment)

Tests were made over different internet providers and the result is the same. As soon as HTTPS is accessed via Cloudflare, the performance drop is enormous.

Did anybody have similar problems, or any idea what cause this problem with HTTPS. It looks like this problems occours since yesterday.

I can confirm the low speed of that file. Here’s a recent thread with a similar problem. There is a mention of the possibility of Cloudflare throttling your speed:

I have make already a ticket to the support aswell. Sadly i got no awnser until now. I have mp4 files on the server but they are not cached on cloudflare. In my example everything that is loaded through https is totally slow. I have other domains, aswell on cloudflare but there this problem not occurs. So if somebody would at a shaper or throttling just for the domain with the problem, in minium some information should be send or visible for the customer.

That may indicate a reason for just that one domain being throttled.

I never created any Page Rule to cache any mp4 Files. So if i read through i found this:

MP4 files aren’t cached by default, but can be cached by using a “Cache Everything ” Page Rule. However, the Terms of Services does impose some limitations on non-HTML caching (section 10).

so if mp4 files arent cached and i set no page rules for that it should be not a problem.

Or did i see this wrong ?

Section 10 is Indemnification. 2.8 addresses non-HTML traffic.

But if something like this would be applied, i could fully understand it, but some visual mark up or information in the dashboard would be the minimum not ? So the customer understand, ok probably i make something wrong, i have to fix it or found another solution.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.