Exposing IPs

I’m seeing the following message on my DNS page.

A few more steps are required to complete your setup.

Hide Some of your DNS only records are exposing IPs that are proxied through Cloudflare. Make sure to proxy all A, AAAA, and CNAME records pointing to proxied records to avoid exposing your origin IP.

Does anyone know what needs to be changed to stop the IP address from being exposed?

Thanks in advance.

You’re probably hosting email on the same server as your website. There’s no way to hide your website’s IP address if you’re set up this way, as email needs direct connections to your server.

Just to add to this, if you install fail2ban and ufw (or equiv firewall for your distro) on your server, it shouldn’t matter. You will always have China/Russia bots spamming your server once you register an IP anyways (especially if you are setting up a mail server because hijacking it has a large potential reward), so its always a good idea to harden your server’s security. This write-up by Linode is really helpful.

1 Like

Hi sdayman, thanks for the info.

1 Like

Hi Evan2 thanks for the extra info. good to know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.