Exporting DNS zone from GoDaddy (Bind, Unix), but can't import

Exported a DNS zone via GoDaddy (tried both Unix and Windows versions), tried importing into Cloudflare, but shows as no records are found. Exporting the Cloudflares auto generated DNS zone to the BIND format, file seems pretty much with the same syntax:

From GoDaddy:
; SOA Record
x.y. 600 IN SOA ns49.domaincontrol.com. dns.jomax.net. (
2019041702
28800
7200
604800
600
)

; A Records
@ 604800 IN A 185.185.x.y
aconnect 3600 IN A 185.185.x.y
atom 3600 IN A 192.168.x.y
backup 3600 IN A 192.168.x.y
brans 3600 IN A 198.1.x.y

From Cloudflare, exporting the auto generated:
;; SOA Record
x.y. 3600 IN SOA x.y. root.x.y. 2030949756 7200 3600 86400 3600

;; A Records
x.y. 1 IN A 185.185.x.y
backup.x.y. 1 IN A 192.168.x.y
cn.x.y. 1 IN A 212.70.x.y
en.x.y. 1 IN A 212.70.x.y

Are they different versions of BIND formats or is the import process just broken?

Try removing the SOA record altogether or at least place it all on one line.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.