Expired SSL

dash-dns
dash-crypto
#1

My SSL is saying it’s expired. I followed what I found in other posts that said to disable universal SSL, wait 10 minutes and then re-enable. This hasn’t worked any of the 3 times I tried it.

Please help! How do I fix this?

#2

SSL shouldn’t expire, as Cloudflare auto-renews them for you. What’s the domain?

#4

That one isn’t going through Cloudflare right now. It’s probably set to :grey: in your DNS page. Which SSL setting have you been using here? Flexible, Full, or Full (Strict)?

#5

Flexible, I am not sure why it wasn’t routing through cloudflare. I did a cache purge yesterday but never touched the DNS settings. Do you think that did it?

I changed the dns as per your advice and I’m back up and running - thank you!

1 Like
#6

I set the traffic to go through cloudflare earlier - and then the SSL had an issue again and when I looked, cloudflare had it set to NOT go through CF.

Any idea why this may be changing on its own? Seems to be the root of the issue

#7

Cloudflare doesn’t go around changing settings on its own…unless something’s really broken, but I’ve not seen that.

In the Cloudflare Dashboard, check the Audit Log for these actions. Oftentimes it’s an API call from a third party (or plugin) that’s connecting to your Cloudflare account and making the changes…using an API key that you gave them.

You can also go to your Profile and Reset the API key if this is the problem, or you just want to rule it out.

1 Like
#8

This is all very helpful - I reset the api keys just to be sure (Even though I haven’t given any out to the best of my recollection.)

Thank you again for your help, truly appreciated.

1 Like
closed #9

This topic was automatically closed after 30 days. New replies are no longer allowed.