Exhaustive Web Testing Skipped error for our PCI DNS scan

Good morning community!

We are currently trying to run a PCI DNS scan using the Qualys platform for one of our websites,
but we see the scan failing due to error:

Exhaustive Web Testing Skipped
With the following explanation:

The web server stopped responding to 4 consecutive HTTP requests 2 minutes ago. Although it resumed responding to a new HTTP request but the service had terminated further scanning of the web server to avoid interrupting the web server’s normal functionality and a prolonged scanning time.

Threat:
The service aborted the scanning of the Web server before completion, since the Web server stopped responding to HTTP requests during the course of scanning. The service attempted to reconnect to the Web server two minutes later and found it responsive again. However, the service has stopped further scanning of the Web server to avoid possible interruption of the Web service.

Solution:
There may have been a number of conditions that contributed to this issue. The following is a partial list of possibilities that should be investigated:

  • The Web server may have reached its connection limit.
  • The Web server (or an intervening network device) may have been purposefully throttling connections (e.g. mod_throttle for Apache).
  • The Web server (or an intervening network device) may contain an undisclosed Denial of Service condition that was triggered by the scan traffic.
  • The Web server (or an intervening network device) may have experienced a degradation of performance due to high load (e.g. via scanning multiple virtual IPs on the same physical host).
  • The scan traffic may have been traversing a network segment with limited bandwidth capacity.
  • An Intrusion Prevention System, reactive firewall, or similar device may have detected and blocked the scan traffic.

IMPORTANT => In the past, we did not encounter the above problem when running a PCI scan.
Since moving our hosting to AWS we have encountered this problem.
Is there maybe some configuration required on AWS which we missed and which is ultimately causing this error?

As a first attempt to solve this error we got we already whitelisted our PCI scanner IPs on Cloudflare, but after running another scan, we still get the same error.

Could someone advise us on how to get around this problem?
Many thanks!

@MoreHelp

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.