Excluded routes in Teams using Warp-cli not working

Is there any reason why warp-cli add-excluded-route 172.24.0.0/16 doesn’t stick?

The command says success and I can see the UserOverride command in the warp-srvc daemon with the route excluded but is not working

Is it because I am using Warp in Teams that I don’t have control?

Is there a setting I could change in the CF Access page, I am the admin?

Here is warp-svc


UserOverrides updated: UserOverrides { version: Some(Current), always_on: Some(true), operation_mode: None, disable_for_wifi: None, disable
_for_ethernet: None, disable_for_networks: None, families: None, dns_log_until: DnsLogUntil(None), gateway_id: None, onboarding: None, organization: Some(Ascii("lionixcom")), split_config: Some(Exclu
de { ips: [(ff05::/16, None), (ff04::/16, None), (ff03::/16, None), (ff02::/16, None), (ff01::/16, None), (fe80::/10, Some("IPv6 Link Local")), (fd00::/8, None), (255.255.255.255/32, Some("DHCP Broad
cast")), (240.0.0.0/4, None), (224.0.0.0/24, None), (192.168.0.0/16, None), (192.0.0.0/24, None), (172.16.0.0/13, Some("172.16 to 172.23")), (169.254.0.0/16, Some("DHCP Unspecified")), (100.64.0.0/10
, None), (10.0.0.0/8, None), (172.25.0.0/16, Some("172.25 to 172.31")), (172.24.0.0/16, Some("CLI exclude"))], hosts: [] }), fallback_domains: Some([FallbackDomain { suffix: "home.arpa", description:
None, dns_server: None }, FallbackDomain { suffix: "corp", description: None, dns_server: None }, FallbackDomain { suffix: "domain", description: None, dns_server: None }, FallbackDomain { suffix: "
home", description: None, dns_server: None }, FallbackDomain { suffix: "host", description: None, dns_server: None }, FallbackDomain { suffix: "internal", description: None, dns_server: None }, Fallb
ackDomain { suffix: "intranet", description: None, dns_server: None }, FallbackDomain { suffix: "invalid", description: None, dns_server: None }, FallbackDomain { suffix: "lan", description: None, dn
s_server: None }, FallbackDomain { suffix: "local", description: None, dns_server: None }, FallbackDomain { suffix: "localdomain", description: None, dns_server: None }, FallbackDomain { suffix: "loc
alhost", description: None, dns_server: None }, FallbackDomain { suffix: "private", description: None, dns_server: None }, FallbackDomain { suffix: "test", description: None, dns_server: None }, Fall
backDomain { suffix: "smartroute.zeland.net", description: Some("CLI add"), dns_server: None }]), proxy_port: None, disable_connectivity_checks: None, override_api_endpoint: None, override_doh_endpoi
nt: None, override_warp_endpoint: None, override_tunnel_mtu: None }

Include / exclude routes for Teams Clients are managed at th organizational level:

Thanks !
So a user in Teams, cannot exclude a route/host manually? It is all hardcoded by the Org? its all or nothing?

Correct, an org is intended to provide settings to be applied to the devices under management.

1 Like

Gotcha thanks for the clarification.
Is there a place where I can suggest a warning in the CLI so it is clear that the command is not successful?

Also, if I do it using Linux ip commands it should work right?

It probably is successful until the settings applied by the org overwrite it.

Probably not, but I don’t have a machine to test.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.