Exclude Googlebot from Web Analytics

The Cloudflare Analytics (not web analytics tab from the domain but the one with the script) seems to be triggered by Googlebot so it is counted in final numbers.

Yes, I know it can be filtered on the report, but it’s the only crawler that triggers the script.

Can I suggest this should not be the behaviour?

I use the tagged analytics instead of the traffic analytics because I explicitly want to see human (or close to human) visits/page views. The web analytics tab shows all requests, human or not.

Capture

[Edit: for the moment, I have changed the code to not present the script if visitor is Googlebot]

Thanks for your feedback and yes it would be good to have an easy way to exclude Bots. For now, please use the filter to exclude traffic for bots by selecting individual component. We will improve the filter to have more flexible options for this. Thank you!

1 Like