Every day in the same time I have a lot of requests - DDoS testing?

Recently every day about the same time (for a couple of hours) I have a lot of uncached requests going to my main page. As I checked the logs they are different browsers, and I can’t find a pattern. Is this some kind of DDoS? How can I avoid this? It is slowing down my site and I have no control over how to end it.

Edit: probably they don’t avoid caching, they just don’t request static resources.

@user7022

Uncached requests are the sum of all requests where CacheCacheStatus doesn’t equal to hit , stale , updating , or ignored .

I would suggest you once disable caching, also disable rocket-loader if your site is based on javascript or HTML, let me know if it helped for you

That graph on the image is hourly. Those visitors doesn’t seem to do anything, they are just somehow avoid caching, and slow my site down. In the rest of the day the site works fine. (Rocket Loader is off.)

Have you disabled caching?

Could you explain why I should disable caching? At the rest of the day it works fine. I’d like to understand it.

I’d rather filter / block these probably bot requests - not sure how. Can I do it from .htaccess?

  1. Only static files are cached by default. Have you created a Page Rule with Cache Everything?
  2. Responses are only cached in the PoP of the visitor by default. Have you enabled Tiered Caching?

If you’re able to identify a common pattern, you can create a Firewall Rule blocking those requests. You could also try enabling Bot Fight Mode if you haven’t already.

You are having a lot of uncached requests, that’s why I am suggesting you to disable caching, it’s your wish at the end whether you want to enable or disable cache!

It is just for a few hours every day otherwise it works fine - you can see that it is in sync with the request count.

It is for a few hours every day. The requests as you see jump to 10 times above normal. Unfortunately I don’t see a pattern for these visitors, based on the user agents they seem to be browsers, but not executing Javascript, like a zombie farm - so Bot Fight Mode won’t help, as the requests already slow down the sytem.

Hmm, could it be that you only cache the response for 24 hours? You could try upping the Edge Cache TTL using a Page Rule and see if that helps.