Errors on Building Application

I’m trying to build my application, but it always fails with this error. PS: I can successfully build locally, and frontend/build is the correct directory.16:23:08.681 Cloning repository... 16:23:09.580 From https://github.com/ElchinFarhad/VaqifProject 16:23:09.581 * branch 0be0ca2287d78584e1679f623cded277eda25f9e -> FETCH_HEAD 16:23:09.581 16:23:09.615 HEAD is now at 0be0ca2 fix: hotel data updated 16:23:09.615 16:23:09.697 16:23:09.719 Success: Finished cloning repository files 16:23:11.007 Checking for configuration in a wrangler.toml configuration file (BETA) 16:23:11.008 16:23:11.147 No wrangler.toml file found. Continuing. 16:23:11.244 Installing dependencies 16:23:11.249 Python version set to 2.7 16:23:13.477 v12.18.0 is already installed. 16:23:14.292 Now using node v12.18.0 (npm v6.14.4) 16:23:14.422 Started restoring cached build plugins 16:23:14.431 Finished restoring cached build plugins 16:23:14.732 Attempting ruby version 2.7.1, read from environment 16:23:16.003 Using /opt/buildhome/.rvm/gems/ruby-2.7.1 16:23:16.647 Using PHP version 5.6 16:23:16.719 5.2.5 is already installed. 16:23:16.733 Using Swift version 5.2.5 16:23:16.733 Started restoring cached node modules 16:23:16.741 Finished restoring cached node modules 16:23:16.944 Installing NPM modules using NPM version 6.14.4 16:23:18.152 npm WARN read-shrinkwrap This version of npm is compatible with lockfileVersion@1, but package-lock.json was generated for lockfileVersion@3. I'll try to do my best with it! 16:23:21.939 npm WARN deprecated @babel/[email protected]: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-class-properties instead. 16:23:21.958 npm WARN deprecated @babel/[email protected]: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-nullish-coalescing-operator instead. 16:23:21.971 npm WARN deprecated @babel/[email protected]: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-numeric-separator instead. 16:23:21.972 npm WARN deprecated @babel/[email protected]: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-optional-chaining instead. 16:23:21.988 npm WARN deprecated @babel/[email protected]: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-private-methods instead. 16:23:24.270 npm WARN deprecated [email protected]: Use your platform's native atob() and btoa() methods instead 16:23:26.478 npm WARN deprecated [email protected]: This SVGO version is no longer supported. Upgrade to v2.x.x. 16:23:28.688 npm WARN deprecated [email protected]: This package has been deprecated and is no longer maintained. Please use @rollup/plugin-terser 16:23:28.806 npm WARN deprecated [email protected]: [email protected] 16:23:28.868 npm WARN deprecated [email protected]: It is not compatible with newer versions of GA starting with v4, as long as you are using GAv3 it should be ok, but the package is not longer being maintained 16:23:29.795 npm WARN deprecated [email protected]: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compatibility 16:23:32.357 npm WARN deprecated [email protected]: Please use @jridgewell/sourcemap-codec instead 16:23:32.724 npm WARN deprecated [email protected]: Use your platform's native DOMException instead 16:23:32.806 npm WARN deprecated [email protected]: Use your platform's native performance.now() and performance.timeOrigin. 16:23:51.973 16:23:51.973 > [email protected] postinstall /opt/buildhome/repo/node_modules/core-js 16:23:51.973 > node -e "try{require('./postinstall')}catch(e){}" 16:23:51.974 16:23:52.078 Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 16:23:52.078 16:23:52.079 The project needs your help! Please consider supporting core-js: 16:23:52.079 > https://opencollective.com/core-js 16:23:52.079 > https://patreon.com/zloirock 16:23:52.079 > https://boosty.to/zloirock 16:23:52.079 > bitcoin: bc1qlea7544qtsmj2rayg0lthvza9fau63ux0fstcz 16:23:52.079 16:23:52.079 I highly recommend reading this: https://github.com/zloirock/core-js/blob/master/docs/2023-02-14-so-whats-next.md 16:23:52.079 16:23:52.091 16:23:52.091 > [email protected] postinstall /opt/buildhome/repo/node_modules/core-js-pure 16:23:52.091 > node -e "try{require('./postinstall')}catch(e){}" 16:23:52.091 16:23:53.015 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.016 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.016 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.016 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.016 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.016 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.016 npm WARN notsup Unsupported engine for @remix-run/[email protected]: wanted: {"node":">=14.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.016 npm WARN notsup Not compatible with your version of node/npm: @remix-run/[email protected] 16:23:53.017 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.017 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.017 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.017 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.017 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.017 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.018 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.018 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.018 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.018 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.018 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.018 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.018 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=12.22.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.018 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.018 npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^2.3.2 (node_modules/react-scripts/node_modules/fsevents): 16:23:53.018 npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 16:23:53.018 npm WARN notsup Unsupported engine for @eslint-community/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.019 npm WARN notsup Not compatible with your version of node/npm: @eslint-community/[email protected] 16:23:53.019 npm WARN notsup Unsupported engine for @eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.019 npm WARN notsup Not compatible with your version of node/npm: @eslint/[email protected] 16:23:53.019 npm WARN notsup Unsupported engine for @eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.019 npm WARN notsup Not compatible with your version of node/npm: @eslint/[email protected] 16:23:53.019 npm WARN notsup Unsupported engine for @humanwhocodes/[email protected]: wanted: {"node":">=12.22"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.019 npm WARN notsup Not compatible with your version of node/npm: @humanwhocodes/[email protected] 16:23:53.019 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.019 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.019 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.020 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.020 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.020 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.020 npm WARN notsup Unsupported engine for @typescript-eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.020 npm WARN notsup Not compatible with your version of node/npm: @typescript-eslint/[email protected] 16:23:53.020 npm WARN notsup Unsupported engine for @typescript-eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.020 npm WARN notsup Not compatible with your version of node/npm: @typescript-eslint/[email protected] 16:23:53.020 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0","npm":">=6"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.020 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.020 npm WARN notsup Unsupported engine for @typescript-eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.020 npm WARN notsup Not compatible with your version of node/npm: @typescript-eslint/[email protected] 16:23:53.021 npm WARN notsup Unsupported engine for @typescript-eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.021 npm WARN notsup Not compatible with your version of node/npm: @typescript-eslint/[email protected] 16:23:53.021 npm WARN notsup Unsupported engine for @typescript-eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.021 npm WARN notsup Not compatible with your version of node/npm: @typescript-eslint/[email protected] 16:23:53.021 npm WARN notsup Unsupported engine for @typescript-eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.021 npm WARN notsup Not compatible with your version of node/npm: @typescript-eslint/[email protected] 16:23:53.021 npm WARN notsup Unsupported engine for @typescript-eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.021 npm WARN notsup Not compatible with your version of node/npm: @typescript-eslint/[email protected] 16:23:53.021 npm WARN notsup Unsupported engine for @typescript-eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.022 npm WARN notsup Not compatible with your version of node/npm: @typescript-eslint/[email protected] 16:23:53.022 npm WARN notsup Unsupported engine for @typescript-eslint/[email protected]: wanted: {"node":"^12.22.0 || ^14.17.0 || >=16.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.022 npm WARN notsup Not compatible with your version of node/npm: @typescript-eslint/[email protected] 16:23:53.022 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=12.20"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.022 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.022 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=12.20"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.022 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.022 npm WARN notsup Unsupported engine for @csstools/[email protected]: wanted: {"node":"^14 || >=16"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.022 npm WARN notsup Not compatible with your version of node/npm: @csstools/[email protected] 16:23:53.023 npm WARN notsup Unsupported engine for @csstools/[email protected]: wanted: {"node":"^14 || ^16 || >=18"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.023 npm WARN notsup Not compatible with your version of node/npm: @csstools/[email protected] 16:23:53.023 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14.0.0"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.023 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.023 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">= 14"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.023 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.023 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=16 || 14 >=14.17"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.023 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.023 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.023 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.023 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">= 14"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.024 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.024 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=16 || 14 >=14.17"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.024 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.024 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.024 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.024 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=16 || 14 >=14.17"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.024 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.024 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.024 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.024 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=16 || 14 >=14.17"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.024 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.025 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=16 || 14 >=14.17"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.025 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.025 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":">=14"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.025 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.025 npm WARN notsup Unsupported engine for @pkgjs/[email protected]: wanted: {"node":">=14"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.025 npm WARN notsup Not compatible with your version of node/npm: @pkgjs/[email protected] 16:23:53.025 npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":"14 || >=16.14"} (current: {"node":"12.18.0","npm":"6.14.4"}) 16:23:53.025 npm WARN notsup Not compatible with your version of node/npm: [email protected] 16:23:53.025 npm WARN @apideck/[email protected] requires a peer of ajv@>=8 but none is installed. You must install peer dependencies yourself. 16:23:53.025 16:23:53.029 added 1588 packages from 723 contributors and audited 1592 packages in 34.909s 16:23:53.498 16:23:53.499 271 packages are looking for funding 16:23:53.499 run npm fundfor details 16:23:53.499 16:23:53.499 found 2 vulnerabilities (1 moderate, 1 high) 16:23:53.499 runnpm audit fixto fix them, ornpm audit for details 16:23:53.541 NPM modules installed 16:23:53.581 Installing Hugo 0.54.0 16:23:54.339 Hugo Static Site Generator v0.54.0-B1A82C61A/extended linux/amd64 BuildDate: 2019-02-01T10:04:38Z 16:23:54.341 Started restoring cached go cache 16:23:54.351 Finished restoring cached go cache 16:23:54.423 go version go1.14.4 linux/amd64 16:23:54.433 go version go1.14.4 linux/amd64 16:23:54.436 Installing missing commands 16:23:54.436 Verify run directory 16:23:54.436 Executing user command: npm run build 16:23:54.683 16:23:54.684 > [email protected] build /opt/buildhome/repo 16:23:54.684 > react-scripts build 16:23:54.684 16:23:56.283 Creating an optimized production build... 16:23:59.550 One of your dependencies, babel-preset-react-app, is importing the 16:23:59.550 "@babel/plugin-proposal-private-property-in-object" package without 16:23:59.550 declaring it in its dependencies. This is currently working because 16:23:59.550 "@babel/plugin-proposal-private-property-in-object" is already in your 16:23:59.551 node_modules folder for unrelated reasons, but it may break at any time. 16:23:59.551 16:23:59.551 babel-preset-react-app is part of the create-react-app project, which 16:23:59.551 is not maintianed anymore. It is thus unlikely that this bug will 16:23:59.551 ever be fixed. Add "@babel/plugin-proposal-private-property-in-object" to 16:23:59.552 your devDependencies to work around this error. This will make this message 16:23:59.552 go away. 16:23:59.552 16:24:15.228 Compiled successfully. 16:24:15.228 16:24:15.228 File sizes after gzip: 16:24:15.229 16:24:15.247 122.05 kB build/static/js/main.3710e1f2.js 16:24:15.247 1.78 kB build/static/js/453.831eb212.chunk.js 16:24:15.247 770 B build/static/css/main.20b8cb67.css 16:24:15.247 16:24:15.248 The project was built assuming it is hosted at /. 16:24:15.248 You can control this with the homepage field in your package.json. 16:24:15.248 16:24:15.248 The build folder is ready to be deployed. 16:24:15.248 You may serve it with a static server: 16:24:15.248 16:24:15.248 npm install -g serve 16:24:15.248 serve -s build 16:24:15.249 16:24:15.249 Find out more about deployment here: 16:24:15.249 16:24:15.249 https://cra.link/deployment 16:24:15.249 16:24:15.351 Finished 16:24:15.352 Note: No functions dir at /functions found. Skipping. 16:24:15.352 Validating asset output directory 16:24:15.352 Error: Output directory "frontend/build" not found. 16:24:16.267 Failed: build output directory not found

This indicates that the directory frontend/build is not prevent after the build steps are completed. Maybe this should be build instead?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.