Error while uploading CSV file to create new List in Zero Trust


When I try to upload a csv file to add a new list on Cloudfare Zero Trust, I get error like “no multipart boundary param in Content-Type”.

I have also tried with example csv file provided by Cloudfare. I could.t find any improvements.

Can anyone look into this issue?


When trying to upload csv file of domains list, for crating Zero Trust List, it gives error “no multipart boundary param in Content-Type”.

Tried many different formats; comma separated, new line separated, coma and new line separated, etc.
Tried even with Sample CSV File ( from the help docs ( ).


1 Like

Thank you for the reports. I have escalated this.

1 Like

Thanks, @Cyb3r-Jak3 I can see the ticket.
@subashmuthusamy777 & @semrubo Could you also raise a ticket for this and share the ticket number here, so we can better track this on our side?

Hi @jochen , thanks for taking care of the issue.
I am on the free plan, and as I can understand I am not allowed to open ticket other than for billing, account, and registrar issues.

Hai @jochen
I am also using the free plan. I have noticed @semrubo saying free plan subscribers can’t raise ticket for this.
I am not aware of the plan benefits.
Please let me know if I can help you tracking the cause for issue.
Also, I request you to provide updates if the issue got resolved.
Thanks in Advance.

@semrubo & @subashmuthusamy777
Please open them as an account ticket, but make sure to mention that the tickets are technical related and link to this community post. Please post the ticket numbers once you do.

Hai @Cyb3r-Jak3

I think it doesn’t allow to raise ticket.

Hai @jochen

For reference, I am attaching screenshot of the file contents that I was trying to upload. I am using Windows OS on my host machine.

Thanks all.

@jochen Please use 2639199 Ticket number if possible


Thanks for your patience on this matter, it has now been escalated internally.
Our Engineering team is now reviewing this issue, and we will provide you an update here once we get more feedback.

1 Like

@subashmuthusamy777 @semrubo
Got an update that this should be fixed now, and it is fixed for me.

1 Like

Hai @Cyb3r-Jak3

Thank you very much for the update.

The issue is fixed now. Now I am able to create lst by uploading csv.

Kind Regards,


Hey @Cyb3r-Jak3 , @jochen ,

I confirm that it is solved in my scenario too.
I have successfully created lists by uploading .csv file.

Thank you guys for prompt handling of the issue.