Error When Starting up my first use of CloudFlare


#1

We are using Dreamhostdotcom to host our site. They provide an option to turn on CloudFlare. I selected their plus edition which is between free and pro.

My problem, when I enable it on my production server, after about 30 minutes I receive a page when navigating to my website that says.

This site can’t provide a secure connection.

my domain name sent an invalid response.

ERR_SSL_PROTOCOL_ERROR

Dreamhost has verified by SSL and it is active, when I navigate to my page, it is secure.

Any thoughts on what I can do. I have attempted turning on Cloudflare twice to have it fail. It seems to be working on my dev site which is a subdomain of my main site.

Dan


#2

This is probably because Cloudflare doesn’t have an SSL certificate issued for your site yet.

Do you have access to a Crypto Settings page for Cloudflare? There should be an SSL certificate status indicator, such as Active, or in process.


#3

Thanks for the reply. My SSL is actually supplied by Comdo. My site is secure. I don’t see anything about stating Active or In Process.

I do see this section.

Edge Certificates

Manage and purchase SSL certificates that will be served to your web visitors.

Your plan includes a Cloudflare Universal SSL certificate pack. To get a dedicated certificate with custom hostnames place a certificate order.

Your plan does not allow you to upload any SSL certificates, but you may order an auto-renewing certificate or upgrade to the Business plan to enable this feature.


#4

Does that Edge Certificates section show a certificate? On the Cloudflare dashboard, it would list a Universal Certificate.

For additional support, you should contact DreamHost and ask about the certificate for your Cloudflare reverse proxy.

If you’d like forum members to take a closer look, post your domain name.


closed #5

This topic was automatically closed after 31 days. New replies are no longer allowed.