Error using CDN "Failed to load assets using CDN URL provided."

I get this error when trying to setup the CDN within Buddy Boss App setup in Wordpress: “Failed to load assets using CDN URL provided. Please enter a valid CDN URL and try again.”. At further review we got found the following:

HTTPS CDN URL: https://www.truesapien.com.cdn.cloudflare.net - see: https://prnt.sc/13t5keo
HTTP CDN URL: http://www.truesapien.com.cdn.cloudflare.net - see: https://prnt.sc/13t5q9l

Not sure where to go from here (I am new to Cloudflare), can anyone help? I did get signed up via SiteGround.

Kind regards,

John

Regarding ERR_SSL_VERSION_OR_CIPHER_MISMATCH in Chrome and Firefox, it may mean that your Cloudflare certificate has not yet provisioned for a domain.

May I ask have you had an SSL certificate already installed at your host/origin server before moving to Cloudflare?

What SSL options have you got selected under SSL tab/settings page at your Cloudflare dashboard?

If you go to SSL/TLS > Edge Certificates in your Cloudflare dashboard, you may see the certificate showing the certificate as ‘Pending Validation’ rather than ‘Active’:

It can take up to 24hrs for the free Universal SSL certificate to provision, if it has been longer than that, try disabling and re-enabling Universal SSL to restart the process. More info and further steps to take in Community Tip - Fixing ERR SSL VERSION OR CIPHER MISMATCH in Google Chrome and Community Tip - Best Practices For Certificate Provisioning .

An article to provide more information:

A good way to check how to propperly setup an SSL with Cloudflare here:

Furthermore, if it could be due to a sub-domain being too deep, but …

Below article could help too:

Regarding ERROR 1001:

If you recently added your domain to Cloudflare and changed nameservers, or activated Cloudflare (:orange: cloud) for a hostname(s), maybe you need to wait for some time due to DNS propagation time.

May I also ask are you using A or CNAME records?

1 Like

The URLs you have entered will not work in the way you expect.

The Plugin you are using appears to be assuming you will store assets on a separate hostname to your main website. That is not how Cloudflare works. Cloudflare usually works by putting the whole website behind their cache, and not by relocating the images,css etc.

The www.truesapien.com.cdn.cloudflare.net value is used as the target of a CNAME DNS record in a partial setup, but cannot be used as a URL (there is no website configured with that hostname). You have already configured your DNS using that record.

Your site is already using the Cloudflare cache, so I suspect you don’t need to configure a specific CDN URL in your Buddy plugin at all.

Thank you - this is actually a CDN for the app we are setting up that is managed using my website wordpress admin too area. It asks for the URL and provides the error “Failed to load assets using CDN URL provided. Please enter a valid CDN URL and try again.” (see image linked here: Screenshot 2021-06-16 at 16.05.39.png - Google Drive). Cannot for the life of me find the URL i am supposed to use. This URL did previously work, or the tool did not previously report an error until we turned it off for a while and then back on again.

Does this shed any more light on the issues? Any ideas ?

Appreciate any support.

Kind regards,

John

I suspect you don’t actually need to configure that at all. Your site is behind a Pull CDN, so everything is served through the CDN, without altering the URLs.

1 Like

Thanks michael, will tak this into account - sounds about right :slight_smile:

A lot there thank you very much. Will dig through it and see where am i am at.

Kind regards,

John

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.