Error updating wordpress plugins

May I ask you to share a screenshot when and where this error occurs?
Furthermore, are you trying to update some specific WordPress plugin or maybe the official one Cloudflare for WordPress?

Does your origin host/server need more time (longer than 100 seconds) to process and execute download, unzip and copy the new files for the needed plugin?

  • like a timeout error or something …

Have you tried tuning-up the PHP at your origin host/server?
I would suggest tuning a bit, if possible, your origin host / server PHP, etc. like below:

memory_limit = 256M
max_execution_time = 300
max_input_time = 1000
max_input_vars = 5000 or 7000
post_max_size = 64M
upload_max_filesize = 32M

Maybe your PHP version is missing some PHP modules which WordPress needs to work with?

Before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Have you temporary tried enabling the “Pause Cloudflare for this site” option from Overview tab of Cloudflare dashboard, or temporary switching DNS records from proxied :orange: to :grey: (DNS-only) to see if anything different?

  • You can pause Cloudflare from the Overview tab of the Cloudflare Dashboard, bottom right under Advanced Actions. If the issue persists after Cloudflare has been paused, it means that there is an issue with your origin, Cloudflare is only operating as your DNS provider while it is paused.

Otherwise, you might want to try and manually update plugins for your WordPress via FTP:

I run tens of WordPress installations on Cloudflare, none of them have issues as you describe while updating plugins.

May I ask what happens when you enable WordPress Debug mode?
Do you see anything in the access, error or debug lof files for an indicator?

Or something is being blocked somewhere, like ModSecurity or Imunify360 if running one of them at your web hosting (usually the cPanel if so).

Also, try to check the CHMOD for the wp-content and plugins directory (default 755, maybe 775 would help in this case for testing?).

Helpful articles: