Error - "This site can’t provide a secure connection"

This site can’t provide a secure connection uses an unsupported protocol.


Is the .energy domain causing the issue here?

There is a valid LE cert on the site and it works fine if I don’t route via Cloudflare.

I have another site on the same server (with a different domain and also using LE) and this is fine via Cloudflare, so not sure what the issue could be (if not the domain).

And the actual domain is?

And did you check if the site is marked as active on Cloudflare?

yes of course - if it wasn’t it wouldn’t be an issue (as it worked fine when not using cloudflare)

In that case it would seem as if your proxy certificate got stuck. This generally has been somewhat of an issue since yesterday and seems to be the case here as well.

What you could try is switching the certificate CA, as that should issue a new certificate and might just get it unstuck.

1 Like

How can I run this?

Via cURL or any other HTTP client.

So I can paste it into a browser somehow?

cURL is not a browser. Please use a search engine for details as that is not strictly Cloudflare related.

I wrote a short tutorial on how to do this:

1 Like

Yes, but you also said any HTTP client (which would include browsers).

They really should make this possible via the UI given how many issues it appears this is used to fix.

Yes, any HTTP client. If you can send a proper PATCH request in your browser, you can certainly use that as well. The feature is currently not even documented and usually you don’t even need it.

Ok, so I ran the command but it failed with the following error:

{“success”:false,“errors”:[{“code”:7003,“message”:“Could not route to /zones/, perhaps your object identifier is invalid?”},{“code”:7000,“message”:“No route for that URI”}],“messages”:,“result”:null}

Now what?

You specified the wrong value in your path. Your domain is not the ID. Please check out the linked example.

So it isn’t! Thanks! It’s now working, I guess there is an issue with their LE certs!

Well, you have switched to Digicert at this point.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.