Error The plain HTTP request was sent to HTTPS port in Plesk

Hello, I just integrated Cloudflare to my website and when I enter the port I get the error “The plain HTTP request was sent to HTTPS port”, I know why, but I use WHMCS and to reconnect plesk I need to automatically forward my web hosting to https again, and I have configured the Cloudflare rules to always redirect to https from that port but it has not worked. Any idea what it could be? Thanks in advance.

How were you making the request to or

If that’s not it - check your encryption mode - Flexible would cause a HTTPS request to be downgraded to HTTP at your origin. Choose Full Strict SSL:

That is only the case for port 443. All other HTTPS ports are Full, use the same port to the Origin.

Port 8443 has to be HTTPS both to Cloudflare and to the Origin.

1 Like

Hello, thank you all for your answer, in that case, in the felixible mode when I enable it, the cloud will load the page superimposed on my website but then it says that it could not be accessed, as if it did not exist, I can only enable SSL from Full onwards

Hello, if I downgraded it to Flexible it would not load the web

I do not understand what you mean.

Flexible mode is only supported for HTTPS connections on port 443 (default port). Other ports using HTTPS will fall back to Full mode.

Cloudflare in general supports two protocols. The HTTP protocol is supported on port 80 and a few additional ports. HTTPS is supported on 443, and some additional ports. You cannot use other protocols on the defined ports. 8443 is a HTTPS port. This means you cannot use it with HTTP, FTP, SSH etc.

In general, the protocol and port to the Cloudflare edge is the port and protocol used to the Origin. The exception is when you enable Flexible, which converts HTTPS on 443 at the Edge to HTTP on 80 to the Origin.

A request like just will not work. It’s like trying to ssh to and expecting it to work. You have to make the initial connection using

Full Strict is the right choice here but as @michael pointed out your issue with port 8443 is not going to be related to Encryption Mode since it doesn’t apply to this port.

Check the URL you’re using as @Cyb3r-Jak3 suggested.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.