Error testing your policy: access.api.error.invalid_user_id

Hello,

I’m experiencing an issue while creating an application access policy.
I created a new allow policy with the only rule to include a group that includes 2 mail addresses. Testing the policy using the first mail address, got access granted but an with the error: “Error testing your policy: access.api.error.invalid_user_id”.
If I test the second mail address present in the group, I have access denied and still the same error “Error testing your policy: access.api.error.invalid_user_id”.
I tried to use only the email addresses and not the group, but the same behavior persists.
Anyone expericing the same issue or have any suggestion?

Thanks

Hello, the issue still persists. I tried a block policy, including everyone, except a test email and I got this:

The only way to get a real output is to use my Cloudflare’s email:

In facts, the rule is working but I’m still seeing the error above, but still unable to insert more than 1 email.
Again, I added my personal/Cloudflare email, and the rule is no longer working:

Am I missing something at this point?