Error SSL When Install

I’m using a wordpress website, when I turn on flexible mode I can’t post. When I use full(strict) I get an SSL error. Please help me fix this problem.

You should always use Full (strict) so get that working.

Did your origin server work correctly using HTTPS before you added Cloudflare?
Ensure it has a valid, signed certificate and works securely when you bypass Cloudflare.

What is the website?

This is: [voguevividvilas.online]

The site is currently bypassing Cloudflare so I can see that the site has a self-signed certificate for localhost.

curl -Ivv https://voguevividvilas.online --insecure
*   Trying 42.119.181.140:443...
* Connected to voguevividvilas.online (42.119.181.140) port 443 (#0)
....
* Server certificate:
*  subject: C=US; ST=Someprovince; L=Sometown; O=none; OU=none; CN=localhost; emailAddress=webmaster@localhost
*  start date: Aug 30 07:12:27 2023 GMT
*  expire date: Jan 14 07:12:27 2051 GMT
*  issuer: C=US; ST=Someprovince; L=Sometown; O=none; OU=none; CN=localhost; emailAddress=webmaster@localhost
*  SSL certificate verify result: self-signed certificate (18), continuing anyway.

To use “Full (strict)” you will need get a full certificate from a CA like Letsencrypt, or you can use a Cloudflare origin certificate, but note that will only be trusted when your site is proxied through Cloudflare and browsers will give a warning if accessing your webserver directly.

(At the risk of being shouted at by @Sandro) You can temporarily use “Full” which will ignore the certificate problems, but that is insecure and must not be a long term solution.

2 Likes

So what should I do now?

This ^^^

1 Like

Thanks ^^

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.