Error on port 443 for install

I recently setup a new VPS to install Discourse. One of the very first steps in the discourse install script attempts to access the IP address on the 443 port, but it does not seem to be accessible through Cloudnet.

I googled and it seems I am not the only one who has encountered this precise issue with cloudflare and Discourse VPS install.

The suggested solution I read was to turn off the proxy for the discourse install so 443 was accessible and then turn it back on after installation, but I purchased the domain name through cloudflare so I’m not sure if that’s even possible or how?

Can’t find anything firewall-ish. Tried turning it off. Also tried a variety of SSL settings including off, but all to no avail.

Any suggestions appreciated.

Is Cloudnet where your VPS is hosted?

What error are you seeing?

No, the VPS is hosted elsewhere.

The error is in the Discourse install script.
“WARNING: Port 443 of computer does not appear to be accessible using hostname

SUCCESS: A connection to port 80 succeeds.”

I finally bypassed the error by turning off the proxy status in the A record.

Then I’m not sure what this “Cloudnet” is you’re trying to access your site through.

And now it’s loading over HTTPS?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.