Error on IOS


#1

Hello,

I’m on wordpress. Before using cloudflare i use wptouch wordpress plugin in order to have nice mobile version.
They have a friendly IOS mode named webapp compatible After i changes my hosting DNS to cloudflare DNS…this IOS very nice mode it stop working.

Webapp mode emulate full screen mode like an real APP. The Safari IOS bar…is hidden in this mode.
I already contact wptouch author and he did not know what is wrong. To understand webapp mode you can follow this link :https://www.wptouch.com/extensions/web-app-mode/

Waiting for a solution.

Here is my site www.stirimeteo.com

Thank you
Nicorel Nicorescu


#2

Hello.

Any help?

Thank you


#3

It looks like it’s working. How does it look for you?


#4

Hello,

Thank you for response.
After installing webb app on your iphone homescreen it should be like

and after cloudflare dns…it looking like

Look at the top of the screen.

Thank you
Nicos


#5

Ok, that’s definitely not what I saw. However, I’m not comfortable installing a web app on my phone to troubleshoot this. I know WP-Touch is reputable, but I just don’t change my phone’s configuration to troubleshoot. Even then, my phone doesn’t give much insight into website interactions, a la Dev Tools.

Maybe someone else can give this a shot.


#6

ok thank you for you effort to understand my issue.

However…there is nothing to install from third party on your phone by installing web app like this. It is apple native thing from IOS…Is only an shortcut on your screen.

Nicos


#7

Yep, similar to Sharing a web page to an App. When I get to work, I can dig out an old iPad Mini and try it on that.


#8

Are you using cache everything? If so, it is possible the issue here is the copy of the page being cached is not the mobile optimized version.


#9

i/m using w3 total cache on wordpress but was no clue before cloudflare.
There are some…cloudflare settings on w3 cache true…

Thank you


#10

Hello,

Any help here?

Thank you


#11

It appears that WP Touch isn’t triggered by an iPad mini.

From what I see about how WP Touch works, this sounds like a caching issue. Personally, I would disable W3 Total Cache and see if this fixes it. But here are some instructions:

https://support.wptouch.com/support/solutions/articles/5000537668-configuring-cache-plugins-for-wptouch


#12

Hello,

Thank for your answer. I already did this settings on W3 Cache. No effect.
All was ok before cloudflare DNS.

Thank you


#13

:frowning:


#14

Maybe the people at WP Touch can help with this, as I don’t know the inner workings of their plugin.


#15

Hello,

Unfortunately WP Touch answer : "From your topic at cloudflare, this started happening when you implemented their service it looks like. So you may want to continue with them and see if they can provide further insight.

Regards,

Emilio Rivera
Support Specialist, WPtouch"


#16

Time for deeper troubleshooting with Page Rules.

Create a Page Rule that matches *stirimeteo.com/* (this will match every single request for your site)
Add a ton of settings. Find every setting that turns features off, like “Disable Apps” “Disable Security” Cache Level: Bypass. Add all those settings.

Then see if your site works. If it does, start turning features back on one at a time until your site breaks.


#17

Hello,

Nothing work :frowning: . Even Pause cloudflare …not working …(but cloudflare still do DNS…).

Seems to be cloudflare dns server settings issue!

I can’t say for sure, but I imagine if the service is caching the site and serving a cached version of it to mobile visitors, then it’s possible that it’s serving the non-web-app version when the user saves the site to their homescreen.

Thank you
Nicos


#18

unfortunately by by cloudflare…:frowning: sick about errors.

Nicos