Error on dynamic page (https://www.bluepalmtechnologies.com): Seem that your website is not behind Cloudflare

Hello, my site “https://www.bluepalmtechnologies.com

I am getting errors when testing cache and also do not see the cf-cache-status: HIT response in any headers. I do not see anything with cf-cache-status at all.

I read the forums and did do the diagnostics. I do get an error on the diagnostics about “The site does not have any DNSSEC records.” but I am unsure how to fix that.

Can someone take a look and point me in the right direction. I have checked that my site uses https in the settings and tried a few other things but obviously I am stumped.

All help is appreciated.

Regards,
David

Full error which others have too:

Page caching seems not working for both dynamic and static pages.

Error on dynamic page (https://www.bluepalmtechnologies.com): Seem that your website is not behind Cloudflare. If you have recently enabled the cache or it is your first test, wait about 30 seconds and try again because the changes take a few seconds for Cloudflare to propagate them on the web. If the error persists, request support for a detailed check.

Error on static resource (This is a Test Page): Seem that your website is not behind Cloudflare. If you have recently enabled the cache or it is your first test, wait about 30 seconds and try again because the changes take a few seconds for Cloudflare to propagate them on the web. If the error persists, request support for a detailed check.

Please check if the page caching is working by yourself by surfing the website in incognito mode 'cause sometimes Cloudflare bypass the cache for cURL requests. Reload a page two or three times. If you see the response header cf-cache-status: HIT , the page caching is working well.

This is correct. For it to be “behind” Cloudflare, that hostname needs to be set to :orange: Proxied. Click on the ‘www’ DNS entry to Edit, then click the :grey: to toggle it to :orange: then Save. Do the same for the ‘bluepalmtechnologies.com’ “A” record.

The bluepalmtechnologies.com and www A record both say Proxied with the orange cloud. . The A record for * is not proxied and still says “DNS only” and that I can only change it with a paid version.

That’s correct. You can not proxy a wildcard record unless you’re on an Enterprise plan. You’d have to specifically add a ‘www’ record in order to proxy it.

I get the error when I test the cache. Is there something else amiss or are some things cached and some are not? How can I tell what is actually cached? I do not see cf-cache-status: HIT in any responses. Thanks for the help.

HTML is not cached by default. You’d have to add a Page Rule for Cache: Everything, and Edge Cache TTL: ≥2 hours. But be very careful when using this, as all users will see the same thing if you cache HTML.

Thank you.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.