Error on adding a domain

I am trying to add a domain I own, and I am receiving the following error:

******.online is not a registered domain

(I don’t want to share the domain name, sorry about that).
The domain does exist, I bought it.

Does anyone know how to solve this issue?

1 Like

I already tried that. Doesn’t help.
This is the first time I encountered this issue, and I have added more than 200 domains using cloudflare.

I’m afraid there isn’t much else we can offer if you can’t share the domain.

The common causes are no nameservers set, nameservers that don’t resolve or changing nameservers to Cloudflare before adding the domain.

It also helps to already have a site that loads at that URL, even if it’s just a Parked Domain page.

The domain is:

As @domjh said, this is looks to be the problem:

It’s also a security risk since someone who already uses those name servers can hijack your domain name.

1 Like

I tried and thought that it will help, but it didn’t. I have reverted back to the default NSs.
I have no clue what to do next.

I’m afraid you still haven’t tried the instructions. There are still no DNS records.
Add two records to the site-dns name servers. One for the domain name, and one for ‘www’, both should be “A” records with an IP address of as a temporary place holder.

As always, it’s best if there’s already a site on the domain, even if it’s just a Parked Domain page.

Thanks, it works now!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.