"[ERROR] No Pages config file found" in build log

Does anyone know what the line [ERROR] No Pages config file found means in my build log? It has started to appear quite recently:

11:12:42.471	HEAD is now at e9bd9c3 Merge branch 'install_updates' into 'main'
11:12:42.471	
11:12:42.557	
11:12:42.557	Using v2 root directory strategy
11:12:42.581	Success: Finished cloning repository files
11:12:44.191	
11:12:44.279	✘ [ERROR] No Pages config file found
11:12:44.279	
11:12:44.280	
11:12:44.283	🪵  Logs were written to "/root/.config/.wrangler/logs/wrangler-2024-04-10_10-12-44_006.log"
11:12:44.293	No wrangler.toml file found
11:12:44.896	Detected the following tools from environment: hugo@extended_0.119.0

It doesn’t appear to cause any issues, so I’m just wondering what it means?

4 Likes

having the same error on my first deploy. Im using nextjs pages router

Happening to me too. I’m deploying a site from a github repo. Deployed fine 2 weeks ago, but it’s throwing this error now.

Also, auto-deployments don’t seem to be working with my repo anymore. Not sure if it’s related to this error or not. The log says it deployed successfully, but the deployed code on my site isn’t updating to reflect the new commits to the repo. I have the site on dev mode as well.

1 Like

i am also facing same issue

I was able to solve it by adding wrangler.toml file to my project with the following sample content:

name = "project-name"
pages_build_output_dir = "./dist"

[vars]
API_KEY = "1234567asdf"
YARN_VERSION = "1"

Reference: Configuration · Cloudflare Pages docs

this solved my no pages config error, but my build stills not working. This error shows up know… any help? Thanks!

	Error: Exit with error code: 1
13:21:02.408	    at ChildProcess.<anonymous> (/snapshot/dist/run-build.js)
13:21:02.409	    at Object.onceWrapper (node:events:652:26)
13:21:02.409	    at ChildProcess.emit (node:events:537:28)
13:21:02.409	    at ChildProcess._handle.onexit (node:internal/child_process:291:12)

It means that there is no wrangler.toml file in the project. This isn’t necessarily a problem so it probably should be treated as a warning rather than an error.

1 Like

Thank you. Yes, if this is the case it should not be flagged as an ERROR since it’s a bit alarmist. Indeed underneath there is already an entry “No wrangler.toml file found” - so this should be enough…

1 Like

I don’t know whether Cloudflare saw this thread, but I’m happy to report that the ERROR message has now gone away and there is modified message about the wrangler.toml being in “beta”:

17:29:47.532	HEAD is now at a10eda8 enhancements using doc generator
17:29:47.533	
17:29:47.617	
17:29:47.617	Using v2 root directory strategy
17:29:47.652	Success: Finished cloning repository files
17:29:49.320	Checking for configuration in a wrangler.toml configuration file (BETA)
17:29:49.321	
17:29:49.420	No wrangler.toml file found. Continuing.
17:29:50.021	Detected the following tools from environment: hugo@extended_0.119.0

Great!! thank you.

2 Likes

Happy to help :slightly_smiling_face:
Yes, this feedback was raised to Cloudflare and addressed with that new message. Glad to see you like it.

1 Like

Thanks very much! Great service.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.