Error Message When Sharing Blog Posts: 301 Moved Permanently

I just implemented Cloudflare on my blog/website (sittinggritty.com) last week. When I attempt to share blog posts, the content no longer previews. Instead, when I try to share a blog post on Facebook it says “301 Moved Permenently.” Please advise where I went wrong in my configuration.

Is there any way to see what it is 301 redirecting to?

Example:
https://sittinggritty.com/dry-heat-melting-in-arizona-heat/

Result:

If the Facebook Sharing Debugger is to trust, HTTPS link goes to HTTP than back to HTTPS.

Even if I try with the HTTP it again goes to HTTPS and then back HTTP.

Canonical link (I see you are using Yoast SEO here) is HTTPS - ok.
Meta og:url is HTTPS - ok.

To troubleshoot:

  1. I am not sure if your WordPress installation is on HTTP or HTTPS? (home_url, blog_url parameters in the settings)
  2. May I ask which SSL option is being selected under SSL/TLS tab at Cloudflare dashboard for your domain? (Flexible, Full …)
  3. Is the Always Use HTTPS option enabled?
  4. Is the Automatic HTTPS Rewrites option enabled?
  5. Or there could be some issue like using the plugin Really Simple SSL (or actually not this one, but …) or some Security plugin?
  6. Do you have some custom Page Rules?
  7. You are using some kind of a WordPress cache x-nananana: Batcache-Hit (not sure if related, but …)
2 Likes

Thank you so much for getting back to me, I’m not a developer – so, bear with me.

  1. I am not sure if your WordPress installation is on HTTP or HTTPS? ( home_url , blog_url parameters in the settings)
    How do I tell?
  2. May I ask which SSL option is being selected under SSL/TLS tab at Cloudflare dashboard for your domain? ( Flexible, Full …)
    Right now, it’s set to full
  3. Is the Always Use HTTPS option enabled?
    Yes
  4. Is the Automatic HTTPS Rewrites option enabled?
    Yes
  5. Or there could be some issue like using the plugin Really Simple SSL (or actually not this one, but …) or some Security plugin?
    I set it up so I think it’s safe to say no.
  6. Do you have some custom Page Rules ?
    Same comment here as the previous question.
  7. You are using some kind of a WordPress cache x-nananana: Batcache-Hit (not sure if related, but …)
    I’m not sure…

Their redirect chain just doesn’t make sense If Step 1 redirected to http, then why doesn’t Step 3 do the same and put it into a redirect loop? Same with the second example.

Am I having this issue because I have both of these enabled?

Is the Always Use HTTPS option enabled?
Yes
Is the Automatic HTTPS Rewrites option enabled?
Yes

No. I generally use both of those as well. It just doubly ensures that your site uses HTTPS.

That’s what I assumed but wasn’t sure.