Error Message “Future home of something quite cool”


#21

Is there a specific reason or is it just a video game thing where getting the high score is an achievement?

If your site is showing “The future home of…” on port 443 it is because your hosting provider hasn’t configured your website to listen on port 443. They can do this without you needing to buy an SSL certificate and you should see the exact same behavior when your site is :grey: in DNS (bypassing Cloudflare) so don’t allow them to tell you it is a Cloudflare issue.


#22

I agree with you but I think all websites should have it enabled at some point in their TLS setup, even without having a strong reason to. Without it it is very trivial for MITM to redirect to non TLS with sslstrip: https://news.netcraft.com/archives/2016/03/17/95-of-https-servers-vulnerable-to-trivial-mitm-attacks.html Note that blog post is from 2016, things have improved since than.


#23

How can I rewrite URLs from “http” to “https” as passive content (such as images) are not rewritten and are still causing mixed content errors and making my website insecure https://www.newfangledscoop.com/ . All these things happen when I turn on SSL to FLEXIBLE.

But when I turn SSL to FULL it shows the message coming “Future home of something quite cool.


#24

Full or Flexible won’t fix the mixed content errors. If it’s set to Flexible then it will talk to your origin server over http (port 80). If it is set to Full then it will talk over https (port 443). I guess the “Future home” message is from when your origin server responds to https traffic so leave it as Flexible unless you can get that sorted.
The mixed content thing can be fixed by “Automatic HTTPS Rewrites” but I’m kind of not a fan of it. I think it is supposed to handle images and stuff but if it doesn’t I don’t really know how to debug it. If I ran a website that did anything then I would probably just fix the URLs at the source. If you are still having mixed content problems then I would do that. Wordpress websites don’t use relative URLs. Instead they have a configuration you can set to change the base URL used everywhere.
https://codex.wordpress.org/Changing_The_Site_URL
The short version is you can set the site URL in a config php file or you can also set it in mysql. If you set it in both then one takes priority over the other. (I think the config file is used over mysql.) If you can change that setting on your site to use https instead of http then maybe it will fix your mixed content problem.


#25

I did enable Automatic HTTPS Rewrites” but but it didn’t work.
I’m unable to edit my posts too.


#26

At this point I suggest you try and fix things at godaddy. There is not much Cloudflare can do since the problem is at the origin server. I’m not sure if they (godaddy) give you access to the web-server configuration via some GUI. If they do than you can fix the “Future home of something quite cool.” yourself by changing what the server is showing on the virtual host on port 443. @cscharff already explained what is going on. 1 Thanks for chiming in :slight_smile: .

@sixcorners offered a fix for the mixed content warnings by changing the Wordpress config. This is the best approach but you need access to the file system or the database. Again I’m not sure if godaddy allows this. I suggest you contact their support and ask if they can change it for you.

Articles/Plugins that might help you with mixed content warnings (I haven’t tried these)




#27

I contacted my hosting provider about changing the port they said


after having a 40minutes of a long conversation


#28

:facepalm:

Ask them if they can add a self signed certificate to your site or add port 443 to the virtual server instance for your site. You shouldn’t have to sign up for a dedicated cert on their site… if they can’t figure it out there are plenty of providers who can…


#29

Capture
But still, the “future home of something quite cool” persist on my website


#30

If you need a cert at your origin then you can actually just get a free one from cloudflare.
Go to the Origin Certificates section on the crypto tab to download a cert. You can give that to your wordpress host.
If they configure SSL then they will probably fix the base URL at the same time.
If you set this up then you can actually set your SSL mode to “Full (Strict)” which is actually what you need if you want to be secure.


#31

“future home of something quite cool” is probably just the default message that shows when their wordpress isn’t configured to host anything.
http wordpress and https wordpress are probably hosting different sites.


#32

it looks your site using Wordpress,
on your WordPress dashboard, install plugins: Really Simple SSL, it quite simple awesome plugins than Cloudflare Flexible SSL plugins;

create pagerule on Cloudflare, format like this:
http:// * domain.tld/ * (remove space between characters stars)

on the Crypto tab, activated “Always use HTTPS”, and “Automatic HTTPS Rewrites”;

refresh your Wordpress Dashboard, you should re-login because SSL active.

now open your index page of your site, if there no any problem green SSL will show-up,
but when it is lack, just check your wp-config,php on the root of your site,
It should be a few lines generated by Really Simple SSL plugins, if it not on there just place this script right after PHP code opening:

//Begin Really Simple SSL Load balancing fix
if ((isset(_ENV["HTTPS"]) && ("on" == _ENV[“HTTPS”]))
|| (isset(_SERVER["HTTP_X_FORWARDED_SSL"]) && (strpos(_SERVER[“HTTP_X_FORWARDED_SSL”], “1”) !== false))
|| (isset(_SERVER["HTTP_X_FORWARDED_SSL"]) && (strpos(_SERVER[“HTTP_X_FORWARDED_SSL”], “on”) !== false))
|| (isset(_SERVER["HTTP_CF_VISITOR"]) && (strpos(_SERVER[“HTTP_CF_VISITOR”], “https”) !== false))
|| (isset(_SERVER["HTTP_CLOUDFRONT_FORWARDED_PROTO"]) && (strpos(_SERVER[“HTTP_CLOUDFRONT_FORWARDED_PROTO”], “https”) !== false))
|| (isset(_SERVER["HTTP_X_FORWARDED_PROTO"]) && (strpos(_SERVER[“HTTP_X_FORWARDED_PROTO”], “https”) !== false))
) {
$_SERVER[“HTTPS”] = “on”;
}
//END Really Simple SSL

refresh your index domain, and back to you Cloudflare dashboard start to purge.


#33

Thank You Everyone:smiley: