“Error (inactive)” using custom domains with Pages

I’m having trouble using Pages with a custom domain. When adding the domain, I see “Error (inactive)” next to the domain name, and when I try to access the site through the custom domain, I get a Clourflare Error 522 page showing the host is timing out.

My DNS records correctly show a proxied CNAME to my _.pages.dev site.

It’s been over 48 hours (4 days) as recommended to allow DNS propagation.

My DNS is propigated and the subdomain is resolving to CloudFlare IPs as expected when checking with dig.

The site is working fine at the *.pages.dev domain.

I’ve tried the following to resolve the issue:

  • Removing and re-adding the domain
  • Removing CAA records on my domain
  • Removing wildcard records
  • Using a different subdomain
  • Removing the domain and manually creating a CNAME record to my x.pages.dev page
  • Waiting a few days to see if it fixes itself

Not sure what the next troubleshooting step is.

One other thing I noticed is that I get a warning that there is a wildcard record on my website when adding the domain though none exists; (and none resolves when checking with dig @1.1.1.1 A noexist.example.org)

16 days now of a broken website and still not able to get this working.

I’ve now also tried:

  • Creating a brand new Pages site from a different Git repo
  • Re-verifying DNS, propigation/resolution via DIG, checking functioning target site at *.pages.dev, etc.
  • Removing TLSA records
  • Removing @ record
  • Adding Pages to root of domain instead of subdomain
  • Waiting a few weeks
  • Emailing Support (unsuccessfully)

On my most recent attempt I got a prompt to set DNS records with my DNS provider, it disappeared after a few seconds.

I’m out of ideas for troubleshooting on my end.

What is the issue you are seeing? Like the site won’t load?

1 Like

When I visit the site through the custom domain, I get a Clourflare Error 522 page showing the host is timing out. Will edit original post to include this.

Please provide your pages.dev and your domain.

The domain is ѕtο​ne​grаy ca (no A record at the moment)

The page in question is l​a​bs ѕt​οnegr​аy ca CNAME’d to g​rаy​lab​ѕ-webѕite.pageѕ.dev

@MoreHelp

It’s been a while since I set up my Pages. Did you create that CNAME before you set the custom domain?

Nope, initially there was no wildcard or record with the same name. I have tried doing that as a troubleshooting step, it didn’t seem to change anything as it appears like Pages automatically overwrites the required dns records during setup if they exist.

@MoreHelp
Offline for 50+ days, what’s my next step here?

“Pages” is @Walshy’s middle name. I’m sure he has an idea or two.

3 Likes

Hey, let me escalate this to the engineers tomorrow. Really wish this gave a better error message but here we are.

Out of curiosity, have you tried linking this to a subdomain? If so, does it have the same issue?

If it does, great please provide that subdomain. If not, could you please re-link it to the apex so it can be looked into?

Thanks (and sorry for the delay)!

3 Likes

Subdomain is labs stonegray ca, pages site is graylabs-website.pages.dev. I have the same issue on a 2nd subdomain and Pages site I set up for testing, foo stonegray ca and stonegray-site.pages.dev as well.

Thanks, I have passed that on!

2 Likes