Error in yarn install within docker build when connected to WARP

Hi,
We encountered an error when we run yarn install within a Dockerfile during docker build, with Cloudflare wrap zero trust turned on.
error An unexpected error occurred: "https://registry.yarnpkg.com/typeorm-encrypted: unable to get local issuer certificate".
We have followed the steps to install and trust the Cloudflare certificate but the result is the same after restarting docker.
The error does not occur when warp zero trust is not connected.

To replicate the problem please use this sample code:

package.json

{
  "license": "ISC",
  "dependencies": {
    "express": "~4.17.1"
  }
}

Dockerfile

FROM node:16-alpine
RUN     mkdir -p /app
WORKDIR /app
COPY package.json  /app/package.json
RUN yarn install

Run the docker build
docker build --no-cache .

Output

[+] Building 2.9s (9/9) FINISHED        
 => [internal] load build definit  0.0s
 => => transferring dockerfi 155B  0.0s
 => [internal] load .dockerignore  0.0s
 => => transferring context: 35B   0.0s
 => [internal] load metadata for   1.6s
 => CACHED [1/5] FROM docker.io/l  0.0s
 => [internal] load build context  0.1s
 => => transferring context: 33B   0.0s
 => [2/5] RUN     mkdir -p /app    0.3s
 => [3/5] WORKDIR /app             0.0s
 => [4/5] COPY package.json  /app  0.0s
 => ERROR [5/5] RUN yarn install   0.8s
------                                  
 > [5/5] RUN yarn install:
#9 0.522 yarn install v1.22.19
#9 0.584 info No lockfile found.
#9 0.601 [1/4] Resolving packages...
#9 0.764 info If you think this is a bug, please open a bug report with the information provided in "/app/yarn-error.log".
#9 0.764 info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
#9 0.764 error An unexpected error occurred: "https://registry.yarnpkg.com/express: unable to get local issuer certificate".
------
executor failed running [/bin/sh -c yarn install]: exit code: 1

Is there a solution to this problem?