Error in CF UI when creating a website in Web Analytics

Hi!

I’m trying to add a website to CF Web analytics. This is not the first time I’m using this feature, and it used to work fine, so it might be a new bug/or something wrong with my setup :slight_smile:

The website is a Discourse forum that is hosted in a subdomain, and this subdomain DNS is handled by CF (but not proxied, just the DNS).

When I try to create the website, I have different errors, from “Internal server error”, to “selected zone is invalid”, see this screenrecording here:

I tried several things:

  • Login/logout
  • Disable adblockers
  • Typing the domain instead of copy-paste

Any idea what could be wrong in my setup ?

Note that I’m not trying to setup this domain automatically, I’m just trying to get the JS snippet to configure this site.

Thanks a lot for your help :pray:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Thanks @arunesh90 for opening my issue again!

It’s still not working unfortunately :confused:

I’ve posted a screenrecording in Cloudflare Discord:

Can you try adding the root domain? It seems like subdomains are accepted only when added as zones via the CNAME setup on Cloudflare.

I am not very familiar with the service, but, if I remember correctly, there should be a way to limit the scope of the analytics after adding the domain.

Thanks to @cf-scott who did some investigating.

The root domain is already added, as it’s our commercial website.

It’s weird because it uses to work, so it might be a regression:

EDIT: tried adding the root domain again, it doesn’t work. It just add the root domain again, and I can’t edit the domain afterwards.

Note that I’m just looking to add a site with a custom JS Snippet installation.

I have asked the CSUP team to take a look, you should have an hopefully more specific reply in the ticket :slight_smile:

1 Like

Sorry @gladysassistant, I thought there was a ticket number here. Do you have a ticket open?

I don’t, I’m not able to create a support ticket, probably because I’m in the free plan.

I just added this to the escalation, I’ll mention it to the next CSUP agent :slight_smile:

1 Like

Test. Try and e-mail [email protected]. It might create a ticket number for you, will be closed, but at least there is a ticket number to reference. Post that number here afterwards. :slight_smile:

1 Like

Just did that, my ticket number is #2438957 :slight_smile:

Thanks a lot for your help!

1 Like

I am escalating this, since I do not see any reason why this should not work. I will update you on the ticket.

2 Likes

Thank you @jochen !

1 Like