Error: DNS_PROBE_FINISHED_NXDOMAIN

Hi. I registered my site leatherfresh.eu in CloudFlare and change NS yesterday . Today it not work with error DNS_PROBE_FINISHED_NXDOMAIN.

Kindly, may I suggest looking into below article for more information about why this error happens and how to trobleshoot:

From above screenshots, it seems to me you are missing some A type DNS records.

Could you re-check your DNS tab at Cloudflare dashboard for your domain?

Later on, make sure it’s proxied :orange:.

Hopefully, you have got an valid SSL certificate installed at your origin host/server for your domain(s) and that your Website is working over HTTPS before moving to Cloudflare?

In case if not, kindly here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

If any other issues appear, follow the needed steps for troubleshooting from article below:

Regarding available SSL options at Cloudflare dashboard, check here:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare CA Origin Certificate (only works for Web traffic!):

Last but not least, kindly have a look here for more information regarding correct SSL settings:

If some errors appear even after checking and configuring the SSL, kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Ports list compatible and supported when using :orange: cloud (proxy mode) on Cloudflare can be found here:

Thank you, but I can,t understand where is my error. Screenshot with DNS image|646x500

1 Like

Few issues from above screenshot to fix:

Kindly make sure to:

  1. A www.new - issue could be here (sub-domain too deep - link from my previous post from above)

  2. CNAME ftp - switch it from :orange: to :grey: cloud (DNS-only)

  3. CNAME mail - remove this one

  4. Add a new record A mail with the content value of your server IP and make it :grey: cloud (DNS-only)

  5. Edit your MX to have the content value mail.leatherfresh.eu.

  6. Add a new record A www with the content value of your server IP and make it :orange: cloud (proxied)

  7. Add a new record A leatherfresh.eu with the content value of your server IP and make it :orange: cloud (proxied)

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.