Error deal

Hello all right, our application handles error alerts for users through stats 500 … etc, internally on the server the returns are correct, showing the treated messages, however when passing through the cloudflare the error stats are always changed to 520 regardless of which return, for example stats 500 error handling the cloudflare changes to 520 by modifying our message, does anyone have any idea which cloudflare config is influencing this?

Hello,

I am sorry to hear you are experiencing issues.

Regarding Cloudflare 520 error, may I suggest you to try looking into below articles to troubleshoot the issue:

Before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Oops okay, maybe I didn’t express myself correctly, my English is horrible,
our site is operating normally, however alerts dealings with user actions, for example, trying to delete an item that is not allowed generates a message on the screen, a treat error, “you can’t delete”, our application running locally the handling of these alerts works normally , however when going through cloudflare the error code is always changed to 520, our team of programmers insists that the cloudflare is acting on some blockage and changing the stats code of the application errors.

Our site is configured https, flexible ssl, http1.1

In that case you have a security issue and your site is insecure. @fritex already posted a link to the relevant article to fix that.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.