Error: Connection is not private in mobile (but works fine in desktop)

Hello guys,

Yesterday I have enabled Free SSL for my website luistimoteo.pt, it is working perfectly in desktop but it is not working in my iPhone, I tried in many browsers but always got the same error.

What is the problem? Any idea? Please help!

Thanks!

Try clearing your browser cache.

Which error do you exactly get? Your www record is not proxied and comes with an invalid certificate, so if you try to access that from your iOS device for some reason you will naturally get a warning.

Using Firefox to emulate an iPhone 6, I can load the non-www site over HTTPS.

Thank you for your replies, guys!

Is not an error, is a (i) icon before the site URL saying that the connection is not secure.
With other sites, example google.com appears the lock icon, but that icon doesn’t appear in mine using a mobile device.

I tried in incognito window too, same (i) icon…

Is this over the same wifi connection as your desktop computer? How is it over cellular?

sdayman, the same happens with both wifi connections.

Is it showing the lock icon in yours?

The sites still working fine for me from a second location and device.

I think something is wrong with my SSL configuration, I still can’t see the lock icon in my mobile browsers.

Also, I can’t even test my website resolutions in tools like this one:
http://quirktools.com/screenfly/

It doesn’t load…
Screenshot: http://take.ms/FZvHS

If I put a different website URL loads without any problem…

Please, any suggestions?

Thank you in advance!

It has to be at your end. Everything seems to be fine everywhere else.

https://www.ssllabs.com/ssltest/analyze.html?d=luistimoteo.pt&hideResults=on&latest

Thank you for your response Withheld.

Well, in that case, I’m not going to worry anymore :slight_smile:

Can you just confirm if you can test my site https://luistimoteo.pt in this tool?
http://quirktools.com/screenfly/

If it loads fine, I will forget this issue once and for all…

Thanks!

Try testing your phone with this test.

https://www.ssllabs.com/ssltest/viewMyClient.html

I’ve found the problem. My website was loading an non-secure image (http://) in the footer on mobile devices, that’s why the locked icon wasn’t showing. After I fix this, the lock icon is showing without problems.

I didn’t found the reason why I can’t use the tool above, but I think everything is working properly.

Thank you for your help, guys!

Have a great weekend!

3 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.