Error configuring your application: access.api.error.invalid_request: invalid 'include' configuration

I’ve been trying to add a new policy to an Application. We have many Applications already configured. The policy I’m adding is the same as is already configured in other Applications.

No matter what I do, when I click save, I get this error:

Error configuring your application: access.api.error.invalid_request: invalid 'include' configuration

Can anybody help me troubleshoot this?

Another weirdness:

We have a policy in this Application that’s been configured for many weeks already, and was working great. It was a “Google Group” include, and it allows access to accounts that are members of a Google Group. It didn’t work when I tried it today (last time I tried it was a couple of weeks ago) so I decided to check the policy.

When I open this policy as if to edit it, and then click “Save” without changing anything, I get the same error.

I solved this. The problem was that somehow, our Google Workspace IdP had lost its brain, and I needed to re-allow it. I did that in Settings / Authentication by pasting the password over the top of the existing one, which enabled a button called “continue setup” or so, which directed me to Google, which asked me to confirm whether I wanted to allow Cloudflare to etc etc.

Not entirely sure why the link broke, but I’m glad it’s working again.

Cloudflare, the error message could be improved. For example, it would be great if it gave me a hint that there was a problem with the IdP link…!

Same issue here. Brand new setup - just authenticated to AzureAD and now getting this error with each change I am trying to make.

Test your AzureAD settings under Settings / Authentication - I think that if they’re not able to connect to the AzureAD, they can’t fetch the groups etc, and well, the error message is unclear.

I got it working again by just opening a private window. AzureAD was working fine. Not sure what caused the issue but it’s resolved for me now. :slight_smile: