Error: An A, AAAA, or CNAME record with that host already exists, did not search

Error: An A, AAAA, or CNAME record with that host already exists. For more details, refer to https://developers.cloudflare.com/dns/manage-dns-records/troubleshooting/records-with-same-name/

I just moved my domain to my own self host and I every time I try and add the root domain name with no sub domain I get the error in the subject.

I have read through other post with the same issue and have deleted the records and such but it is not working still.

A sub domain will work no issue.

It seems like there is already an existing A, AAAA, or CNAME record for your root domain. To resolve this, follow these steps:

  1. Go to your Cloudflare dashboard and navigate to the DNS section.
  2. Look for any A, AAAA, or CNAME records for your root domain (usually represented by @) and take note of any details you may need.
  3. Delete the existing record for your root domain.
  4. Now try adding the new record for your root domain again.

Did that before I made the post and still not working.

Can you share the name of the domain?

The root domain exists in your DNS and is currently set to be proxied,

dig blackmarketfab.com +short
104.21.68.125
172.67.195.13

Ensure the account you are configuring is using the correct nameservers and then review the A, AAAA and CNAME records to locate the current record to delete or modify it as needed,

dig blackmarketfab.com ns +short
aaden.ns.cloudflare.com.
sarah.ns.cloudflare.com.
1 Like


Which IP should go there?

The IP address of wherever you are self hosting the content.

I just figured it out.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.