Error adding site with tk TLD

I just registered a site, which has a .tk TLD ( Right after I registered the site changed the nameservers to the Cloudflare nameservers that I usually get for my domains, because I know that they can sometimes take a while to change. After doing these 2 steps, I went over to put my site on Cloudflare but I got the error “Failed to lookup registrar and hosting information of at this time. Please contact Cloudflare Support or try again later.” I tried with a couple more domains, with other TLDs offered by freenom (such as .ga), but none of them worked either. After a bunch of tries using different devices and browsers, it now says “This web property is temporarily restricted from being added to Cloudflare at this time. Please try again later, or contact Cloudflare Support with any questions.” What should I do? I’ve been able to register freenom domains in the past, so I think it should work but for some reason it isn’t. Here’s a whois lookup that works for tk domains, just search calebharvey on it:

You need to wait until after Cloudflare tells you to change name servers. Before that, the domain needs to resolve through established name servers. Otherwise, you get the failure you’re noting.

This usually clears up on its own.

1 Like

This solved the error and I got my site added, but I’ve clicked the check nameservers about 5-10 times in the past 24 hours and Cloudflare doesn’t seem to recognize that I’ve changed the nameservers, it doesn’t show the site as active on Cloudflare. I checked the nameservers using a whois lookup (see original post for link), and it shows the nameservers as CLOE.NS.CLOUDFARE.COM and TODD.NS.CLOUDFARE.COM, which are the nameservers I was told to set. This happened last time I used a freenom domain and I finally gave up and went to buy a .xyz domain, which worked almost instantly. Last time, it took a week or two before I gave in and bought a new domain, and this website is for a school assignment so I need to get it done before that long. If it doesnt end up working I can try using the freenom DNS but I’d rather use Cloudflare if at all possible.

Nevermind, just realized i made a typo and left the “L” out of cloudflare.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.