Error adding route to Worker

I am trying to add the route* to our Cloudflare worker for and getting this error: “This zone is not configured on your Cloudflare account.”

There is a DNS CNAME record for that error to points to an AWS Cloudfront instance (so is resolvable), and the record is proxied through Cloudflare.

The Cloudflare docs say:

If your route is configured to a hostname, you will need to add a DNS record to Cloudflare to ensure that the hostname can be resolved externally. If your Worker acts as your origin (that is, the request terminates in a Worker), you must add a DNS record.

You may enter a placeholder AAAA record pointing to 100::Open external link, which must be proxied through Cloudflare (orange-cloud in the DNS settings). This value specifically is the reserved IPv6 discard prefix but is not the only value allowed. For example, you may also use an A record pointed to or a CNAME pointed to any resolvable target.

Is this a bug, or is there something that I am missing?

I have to say I’m surprised. I don’t think Workers cares where your DNS record points to, as long as it’s :orange: Proxied.

Are you you sure you’re in the right account for that domain? Prosource is using Cloudflare’s Dan and Sara name servers. These should be at the bottom of the DNS page where your ‘staging’ DNS entry is.

I’m not quite sure I understand your question, “Are you sure you’re in the right account for that domain?”

The DNS URL is:

The workers URL is:

MY_ACCOUNT_ID is the same in both URLs.

I add my Workers routes at:

Also, at the bottom of that DNS page, it shows the two name servers I mentioned?

Ah hah! That was the trick. I was at the wrong location in the UI. It’s now working. Thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.