Error 552 while trying to access HTTPS website

dash-dns
dash-crypto
#1

I have the domain www.param.me which is hosted by GitHub pages and is accessible through HTTPS. But api.param.me is hosted from my personal server which doesn’t have a valid SSL certificate. In an attempt to make api.param.me accessible through HTTPS, I changed the domain’s nameservers to Cloudflare, made sure api.param.me is set to :orange:, and enabled full SSL. But https://api.param.me still times out

Does my server need an SSL certificate as well? Are there any other alternatives?

#2

This is likely due to your SSL setting (in the Crypto tab). This should explain what they mean (also the help text):

And why we would not recommend the insecure Flexible SSL: Why we recommend you don't use flexible!

Can you try setting up SSL/port 443 on your personal server? You can get a free SSL certificate from LetsEncrypt or you can download an “origin certificate” (only valid between Cloudflare and your server):

1 Like
closed #3

This topic was automatically closed after 30 days. New replies are no longer allowed.