Error 550 5.7.1 can't send or receive any email

So I’m using my third party mailbox service, to use the domain email system. However, all my domain email got this error whenever I try to send or test to receive for any email… I already turn off the bouncy message, but I still receive this error…

When I’m still using namecheap this never happends until I send my DNS to Cloudflare to use the CDN.

The domain name is, and

1 Like

Error 550 5.7.1 is a generic error code, covering quite a lot of things where no more specific code exist.

What is the actual error message you see next to that error code?

If your MX record for is pointing to e.g., then you have set to be Proxied (:orange:).

Switch all DNS records that are related to email traffic to Unproxied (:grey:) / DNS-only.

This third party mailbox service you refer to, would that be Namecheap, or who exactly?

Your SPF records are also quite much messed up, and needs adjustments.

If you only use Namecheap, then switch the Content of the v=spf1 TXT record you have on your domains, to this one:.

v=spf1 -all
1 Like

My apologies for the confusion, Here is the error code I received when I try to send mail to
554 5.7.1 [email protected]: Relay access denied

And this is the error looks like whenever I wanted to send email with both domain email (thaigoo4u and vdo)

And the third party tool Im using is called Interworx / Siteworx. how do I add adjust the SPF record?

1 Like

I just tested a couple of minutes ago from my end, and it looks like I can send message(s) just fine to that address quoted, … did you receive anything from

“Relay access denied” is indicating that the mail server you connect to, has not been configured to accept messages for the given domain.

For example, if you set your MX records to point to Google’s mail servers, and that Google’s mail servers aren’t set up to be accepting messages directed to your domain, Google would respond with that specific code/message to other mail servers that are attempting to make deliveries.

The SMTP sever you use to send your messages with, can also refuse to accept messages, with the Relay access denied message see, which would most often be because the email client you use, isn’t authenticating properly with the mail sever, and try to relay (“send”) messages over the server, without authenticating (e.g. with username+password) first.

Various email clients have different ways of how to enable SMTP authentication, so that part can be adjusted, would be something you need to take up with the documentation of your email client.

The error message in this screenshot is however different, and not directly related to the error above, and claims “550 5.7.1 [CSR] Our system has detected an unusual amount of unsolicited email originating from your address. Contact your service provider for support

Since the server named that rejects the message, appears to be (have been?) running on Namecheap, as such, I would normally suggest to contact Namecheap for further assistance about that specific error.

That be, unless you rent an unmanaged server (e.g. dedicated server, root server, VPS, …), that you manage on you own, … in which case you would (obviously) need to figure out the things, on your own.

That said, → I would still start by following the advice from my previous message, about adjusting the Proxy status of the email related records to become Unproxied (:grey:) / DNS-only, and see if that helps.

1 Like

Good day DarkDevil,

My apologies for the long delay. I have solved this issue weeks ago, the cause was one of my server domains has been spams for about 1000 messages, since the tremendous mail queue I was unable to send a message.

But now there’s another problem, I able to receive message from gmail, however I cant receive anything form my sites. I think its the Mail record problem that I set at my DNS record.

Moreover, when I sent a message it end up at Spams… its there something wrong with the SPF, DKIM, and DMARC record there I set at cloudflare?

1 Like

I actually try the third-party mailbox service with another domain, but the DNS is at Namecheap not Cloudflare which is, it’s working. So, I was wondering maybe isn’t able to because it’s misconfigured at the Cloudflare.

1 Like

Here, at my WP mail log able to provide the mail log. there is 3 of them I have try to send form to my mail [email protected]

But at my webmail, it doesn’t display the mails from the site…

1 Like

Based on your screenshot, here’s the changes I would apply:

The red one about “REMOVE PROXY STATUS” is the one I mentioned above, e.g. here:

Besides the above mentions on the screenshot, I would also lean towards a sane DMARC record (e.g. “p=reject” policy), as soon as possible.

I would strongly suggest to make sure that DKIM is (generally) succeeding for your outbound messages first.


Hello DarkDevil,

After I set the record with your guide. the email able to send not at the SPAM, and I able to receive any form from my sites. Thank you very much!

But when I check the email header, it still mention that the DKIM is still FAIL…

I was wondering if you know something, and I would like to ask what is the ‘p’ about? at that DKIM record value

Many thanks,


1 Like

In the header block in the lower area of your screenshot (Delivered-To: …), -

Can you scroll down there, and see at least the one starting with “Authentication-Results:”, but preferably also any “DKIM-Signature:”?

The “p=” value is simply the public key of your DKIM key pair.

DKIM generates a cryptographic seal to your message, you (e.g. typically your sending mail server) have the private key, that is used to generate the cryptographic seal.

Receiving mail servers can then verify the cryptographic seal is (still) intact, using the public key, that is stored under the “p=” value in the DKIM record added to your DNS.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.