Error 526 with my worker is still not resolved

Ok so remember how I had the issue with my worker giving the 526 error?

I temporarily paused Cloudflare


And disabled my worker
image
And ran the link through SSL Checker and it returned these results

So it’s NOT my SSL certificate causing the error, and as mentioned in the last conversation I changed the SSL setting to Full (Strict)
image
The other the thing that was said to cause it is the coding, which is
addEventListener(“fetch”, (event) => {
event.respondWith(
handleRequest(event.request).catch(
(err) => new Response(err.stack, { status: 301 })
)
);
});

/**
*

  • @param {Request} request
  • @returns {Promise}
    */
    async function handleRequest(request) {
    const { pathname } = new URL(request.url);

if (pathname.startsWith("/api")) {
return new Response(JSON.stringify({ pathname }), {
headers: { “Content-Type”: “application/json” },
});
}

if (pathname.startsWith("/status")) {
const httpStatusCode = Number(pathname.split("/")[2]);

return Number.isInteger(httpStatusCode)
  ? fetch("https://aboutrock.godaddysites.com" + httpStatusCode)
  : new Response("Oops, you seem to have hit the incorrect link! You will be redirected shortly, if you are not then try reloading the site");

}

return fetch(“https://www.aboutrock.godaddysites.com/redirect-notice”);
}
But what’s weird is when I send a “GET” request, it shows this error
image
The GET request returns this coding

Error communicating with origin body{margin:0;padding:0}

Uh oh...

Error communicating with origin server www.aboutrock.godaddysites.com

    <section></section><!-- spacer -->

    <div class="cf-section cf-wrapper">
      <h2 data-translate="what_happened">Details</h2>
      <p><code style="font-family:monospace">TLS peer's certificate is not trusted; reason = Hostname mismatch</code></p>
    </div>

    <div class="cf-error-footer cf-wrapper">
      <p>
        <span class="cf-footer-item"><span data-translate="performance_security_by">Performance &amp; security by</span> <a href="https://www.cloudflare.com" target="_blank">Cloudflare</a></span>
      </p>
    </div><!-- /.error-footer -->
  </div>
</div>

Does anyone know what is causing this, all information that I can get has been provided (except for the preview).

Loading the www version of your site, the one you’re using is resulting in a 404 GoDaddy Sites page. Remove the www. and it should be fine. Do use: aboutrock.godaddysites.com

These are the SSL checker results (if that’s what you asked for)

SSL Labs is telling you there:

None of the common names in the certificate match the name that was entered. (www.aboutrock.godaddysites.com)

You can verify for yourself in a browser, or cURL:

😋 $ curl -svo /dev/null https://www.aboutrock.godaddysites.com
*   Trying 72.167.191.83...
* TCP_NODELAY set
* Connected to www.aboutrock.godaddysites.com (72.167.191.83) port 443 (#0)
...
* Server certificate:
*  subject: OU=Domain Control Validated; CN=*.godaddysites.com
*  start date: Jul 14 17:47:41 2020 GMT
*  expire date: Jul 14 17:47:41 2022 GMT
*  subjectAltName does not match www.aboutrock.godaddysites.com
* SSL: no alternative certificate subject name matches target host name 'www.aboutrock.godaddysites.com'

There are 2 things you could do here:

  1. Use aboutrock.godaddysites.com instead of www.aboutrock.godaddysites.com because that is covered by the *.godaddysites.com certificate. Then Full Strict SSL should work just fine without a 526 Error
  2. Downgrade your SSL setting from Full to Full Strict

Of those options 1 allows you to keep Full Strict, so I’d recommend that.

K, I’ll try them both (the 1st option, then if it fails the second)

Is that normal?
image