Error 526 since Google Workspace configuration added

Hello,

I have a weird issue. I have a website https://cyberlife-music.com that doesn’t work anymore since I tried to use Google Workspace to create a DKIM record to use custom mail with gmail since their last update that makes my thing broken.

I don’t know what happens, but now my DNS is died. DNS_PROBE_FINISHED_NXDOMAIN !!

Google had to modify a record when I linked up my domain.

However, when I check out my configuration, nothing looks abnormal :

  • My domain provider linked to my cloudflare DNS
  • DNS points on Heroku cloud which runs my app

But I have DNS_PROBE_FINISHED_NXDOMAIN when I go to https://cyberlife-music.com

When I go to https://www.cyberlife-music.com I have an explaination about SSL being wrong.
But when I look my configuration of SSL, as nothing changed, nothing looks abnormal.

A clue about what could happen with google and SSL?

Thank you!

  1. You don’t have an entry for the naked domain.
  2. Your server certificate is invalid, it may have expired.

Pause Cloudflare and talk to your host to get your site working on HTTPS, once it does it will also work on Cloudflare and you can unpause.

1 Like

What does it mean? What am I supposed to do?

What am I supposed to do with Heroku as their certificate is automatically generated?

You need to configure a DNS entry on Cloudflare, if you want the naked domain to work.

As for the certificate, it probably could not be validated because of the proxies, so it may be better to swich to an Origin certificate.

I already have my DNS entries.
|CNAME|www|objective-persimmon-4fzn1q8evpv0jzot61rt0kjz.herokudns.com|!

Where do I check the naked domain?
I already have configured it in the google workspace (even if it’s not supposed to pass by google I guess)

Otherwise, how can I rollback with google workspace ■■■■?

Yes, for “www” but not for the naked domain.

Again, pause Clouflare and clarify with your host your DNS entries and all certificates

If the CNAME entry you posted is your server address, then you actually have a valid certificate for the naked domain but not for www.

You could simply configure a CNAME entry for the naked domain and redirect www with Redirect www.example.com to example.com

I added A configuration to the IP of the DNS, it looks working but I still have the SSL issue…

Sorry, but you don’t seem to follow the advice.

Yeah I tried to follow google sh** advices but finally I removed the google workspace account.
But there is that thing that doesn’t make sense : the DNS configuration doesn’t mention any google thing.
Now I try to add manually the certificate to heroku. Do you know where I can copy the Cloudflare Origin CA certificate ?

I did it but still have the error…
Doesn’t make sense!
How could I know if the DNS points really (for real) on the heroku server not passing by any google ■■■■?
The DNS is clear: nothing works with google…
How is it possible?

Again, you need to follow the advice provided in this thread.

I paused, but still see this error.

Because you have the wrong DNS entries set up.

Keep it paused and

It doesn’t make sense as the CNAME DNS setup is mapped to the Heroku server.

Actual statement: nothing works.

  • I have paused everything
  • I deleted and tried to re-create a new SSL certificate
  • I removed and retried from scratch a new heroku address, added it into the CNAME entry of cloudflare
  • I removed the A entry…

Nothing work… :confused:

Which steps did I miss or what do I have to do to make the connection clear between the Cloudflare DNS and the heroku server ?

We can’t post media / screenshot nor link lol I’d love to show the configuration, to show you that it’s linked up but heroku can’t resolve DNS ahah

You need to clarify this with your host I am afraid, as Cloudflare is not involved here.