Error 526 on subpages, but not on the main page

I’ve just migrated my WordPress from my own server to the hosting provider and I have a problem with SSL configuration on Cloudflare.

Old configuration

An origin server with Let’s Encrypt, only two domains configured (without any wildcard):

  • emilwypych.com
  • www.emilwypych.com

Cloudflare set to Full Strict mode.

New configuration

A hosting provider with Let’s Encrypt certificate, only two domains configured (without any wildcards):

  • emilwypych.com
  • www.emilwypych.com

The main page after migration works fine (I can see proper and valid SSL certificate from CF):

and the main page is also visible. But when I try to choose some post or page, then I get Error 526:

I was so desperate, that I reached the generation limit of LE, so NOW I’m using an Origin Certificate created in SSL/TLS -> Origin Server section. I created a certificate for the following names:

*.emilwypych.com, emilwypych.com (ssl_tls.crypto_hosts)

If I override the domain in /etc/hosts file to the origin IP address (188.210.221.78) I see that uploaded certificate is visible on the host:

and it has proper names:

but EVEN with the Origin Certificate, this problem still occurs. I still get Error 526 on each page of the https://emilwypych.com

Moreover, even when I try to DISABLE SSL on the Cloudflare side, I see the CF certificate AND Error 526. Changing to Flexible or Full mode doesn’t work as well.

What am I doing wrong?

I’m unable to replicate this. I checked out several pages and posts and never got a 526. I see it’s through the Warsaw datacenter, so there’s a slight chance it’s an isolated issue.

Give this a try to test some URLs:
https://www.dotcom-tools.com/website-speed-test.aspx

1 Like

Hmm, it works now for me too… Seems that it was a temporary problem or something like that… As it was taking about an hour at least.

This topic was automatically closed after 30 days. New replies are no longer allowed.