Error 526 invalid ssl certificate even though SSL certificate installed on the origin server

Hi,

I have valid SSL certificate installed on my origin server hence I have been using Full Strict in Cloudflare, however from today suddenly I’m getting “Error 526 invalid ssl certificate” even though SSL certificate installed on the origin server.

If I pause Cloudflare and access the website its working fine over https, so looks like this is an issue with Cloudflare and also upon checking with the origin server support they also confirmed the same as the certificate is valid on the origin server.

Please let me know what is causing the issue, I don’t want to change from Full Strict to Full for fixing this issue. I would want to continue using Full Strict.

Domain: askeygeek.com

Do you have a valid certificate chain? I mean those including the intermediate certificates.

Yes! valid SSL certificate from Comodo installed on the origin server

Do you mind posting a screenshot of the SSL certificate configuration? If you have access to the server itself.

Oh, looks like you are using cPanel.

Can you click View Certificate and see whether the CA bundle is there? Scroll to the very bottom and you’ll see this:

Yes, Certificate: (CRT), Private Key (KEY) and Certificate Authority Bundle: (CABUNDLE) are there…

You might need to contact Cloudflare Support regarding this issue.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

Yes! I have done that already! Thank you and have a great day ahead :slight_smile:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.