Error 526 even though I've used Cloudflare Origin Certificates

Well, I just followed the advice from “Yo-Motherboard” who said he couldn’t
get it to work without the Root Cert.

I now get a Error 525 SSL handshake failed.

So, I should go and delete this line then ?

SSLCertificateChainFile “/etc/cf_keys/hurtaid-org/cf_root_cert.pem”

% openssl s_client -showcerts -servername good-health.ml -connect 5.101.140.50:443 -quiet </dev/null

4561508012:error:1400410B:SSL routines:CONNECT_CR_SRVR_HELLO:wrong version number

That looks like you have HTTP running on port 443, not HTTPS.

As I said earlier:

I don’t have a certificate now for good-health.ml

I have deleted ALL Lets Encrypt certs - I have even deleted the entire directory etc/letsencrypt

I have now also deleted ALL enabled virtual hosts.

I have only got “hurtaid.org” running on the server now.

Currently I have it on “Flexible” and it is working.

But i really want it to work on “Full (Strict)”

I still get this:

openssl s_client -showcerts -servername hurtaid.org -connect 5.101.140.50:443 -quiet </dev/null

139637061399872:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:…/ssl/record/ssl3_record.c:331:

I have now deleted that Root certificate and re-run the
dpkg-reconfigure ca-certificates

So hopefully back to how it was.

I am thinking that I’ll just uninstall Apache2
and then re install it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.