Error 525 "SSL handshake failed"

Dear community,
I’ve been using Cloudflare for about 7 months successfully. The domain is https://www.linkinfluent.com/
I did nit touch something since then. This afternoon, I found a 525 error “SSL handshake failed”.

I restored my website to a previous date : nothing.
I checked the port 443 is open.
I contacted my host (1and1) since I have no SSL certificate installed with them -they said the issue is with the SSL issuer (Cloudfare).

But, the certificate is “Full”.
And Edge certificates is active.
And all SSL parameters are “On”.

Could you help me to solve this issue please?
Lookinf forward to reading you,
Bests regards.

This would not work. Can you re-check that?
Full or Full (strict) in combination with a missing certificate will cause a 525. Or so you have a self-signed certificate installed there?

It is in “full” (not strict).
My plan includes a shared Cloudflare Universal SSL certificate.

Looking forward to reading you.

I changed it by “flexible” it worked 5 min, now i hava a “ERR_TOO_MANY_REDIRECTS” error

That’s because when you set the SSL setting to flexible, Cloudflare listens on the 80/http port of your origin server. So if your origin servers returns a https redirect on port 80/http, then you get that too many redirects error

Do you know if the certificate on your origin server is up-to-date, functioning correctly, etc?
From what I’m reading, my guess is gonna be that the certificate on your origin server ran out

Thank you for your answer.
I found a solution : the SSL from 1&1 was off. I put it ON again and put the Cloudflare SSL on flexible.
Now it works well again.
Thank youu very much for your messages.

Well, then: set it back to full. Flexile doesn’t encrypt the traffic between CloudFlare and your server.

I already mentioned that. But since SSL wasn’t active @ IONOS: