Error 525 - SSL Handshake Fail + Spike in Traffic

I’ve been using Cloudflare for about half a year successfully. the domain is https://myhomelovely.com/ Nothing touched since then. This morning I have a 525 error, SSL handshake. I contacted my host (1and1) since I have no SSL certificate installed with them -they said the issue is with the SSL issuer ( CLoudflare). The certificate is not expired (195 days left). I have started reading the forum and implemented some suggestions,

  1. tried changing the SSL encryption Mode to no avail.
  2. I noticed a SPIKE in requests, so I turned on Under attack mode. I do think I’m under attack as I used to get some random code displayed when I access the website.
  3. I used some website (is it hacked . com) to check anything odd and it showed me some Cloacked code warning
  4. The last thing If I Pause Cloudflare on Website - but now I get this:

This site can’t provide a secure connection

myhomelovely.com sent an invalid response.
ERR_SSL_PROTOCOL_ERROR

So, am I attacked or something wrong with the SSL certificate? :slight_smile:

Thanks for your help!

Check, if the certificate on your origin has expired or if it has been revoked. If that’s ok:

Hi Mark,

Thanks for the reply. Certificate on the origin server, I just checked in Cloudflare settings- I don’t have that installed and I never did have. Should I create one? Sorry, not techy here.

Sorry for the confusion.

With “origin” i meant your IONOS server (1&1), not Cloudflare’s Origin Certificates.