Error 525 on full or strict full encryption mode

I have tried much of everything to get full strict SSL working. Apache works fine. I have no idea where to pin down the problem at this point. If you want logs or something from the system tell me. Thanks for helping me!

Either your server is not properly responding or you have a firewall in place which blocks Cloudflare.

Have you already tried pausing Cloudflare?

I just tried pausing Cloudflare now I get this error even after I unpaused Cloudflare: Error code: SSL_ERROR_RX_RECORD_TOO_LONG

In that case I am afraid your server is not properly configured.

Keep Cloudflare paused until you fixed the server and once your site loads fine, it will also work with Cloudflare.

Do you know where I can get started fixing my server? Thanks for pinning down the problem for me.

Something in the Apache configuration will be off. Going by the error message I would assume you have not properly set up the SSL configuration and that’s only handling HTTP, but any details are best discussed in an Apache forum or at StackExchange or Reddit.

Turns out when Cloudflare is paused it did load fine over http. enabling Cloudflare again gives error 525 again. Does that change anything?

You were asking for HTTPS, right?

Yes. The site also loads fine with flexible, I obviously want full strict.

Of course, you should change that back to Full Strict and then fix the server. As mentioned, I would keep Cloudflare paused until it is fixed.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.