Error 525, Google site, subdomain

I setup CNAME entry for to point to my google site (new, not classic version of google sites). It worked for a few days, but then stopped, giving Error 525: SSL handshake failed. I can’t figure out how to fix…

I deleted the mapping on gsuite config and set the mapping back up, with no success…

Have heard this might have to do with doing full vs partial SSL or invalid cypher, but am not technical in this area and not sure where to go next…

Any ideas?

  • Damon

Most likely something has changed on the origin in regards to SSL. Try going into your Cloudflare dashboard under the SSL/TLS app and checking your SSL setting (should be at the top). If you change from Full or Full (Strict) to Flexible, it should resolve the issue.

Note that now this will mean that traffic from your origin to Cloudflare may not be encrypted. Further origin related troubleshooting:

Is this problem solved? It seems I am going through this issue now.

Hi @cico, have you tried setting ssl on the SSL/TLS app to Full (Strict) or Full?

Thanks for the reply. It works somehow after 5 hours’ waiting.

1 Like