Error 525 after a week or two

I created myself a vps with Virtualmin on my home network and got some SSL certificates using Let’s Encrypt. I didn’t have any issues, however, after a week or so, cloudflare now returns error 525 whenever I try to access any of the domains. I have gotten new certs from Let’s Encrypt and also tried using the origin certs you can get from cloudflare, both seemed to apply successfully in apache, but I still get error 525 on the cloudflare page whenever I try to access them.
How do I resolve error 525, I don’t see any blatant issues with my SSL/TLS setup in cloudflare that could cause this issue, but my apache server seems to be set up fine as well.

Did you try connecting directly to your server? Does that work? Did you pause Cloudflare?

What’s the domain?

I’ve gray-clouded the raw domain and www. and now I’m getting “ sent an invalid response. ERR_SSL_PROTOCOL_ERROR”, why could this be happening and how do I set it up to work with cloudflare?

That’s an issue with your server then. You need to fix this there I am afraid, that’s not Cloudflare related.

StackExchange might help.

Alright, thanks

Seems your HTTPS port is actually configured for HTTP.

Please explain, what do you mean?

Your port 443 is not properly configured for SSL but responds with regular HTTP

I think this issue was caused by the default website for the raw IP being a redirect to a backend for some reason, after changing the default IP page to a blank parking page, ssl seems to be working everywhere.

This topic was automatically closed after 30 days. New replies are no longer allowed.