Error 524 background - Plan Free

Hello

I’m in need of help.

I’m working in a testing environment and I’m receiving the 524 error message in the background (F12 on the browser), preventing the processing of my files (it’s been happening in the production environment). I noticed that the error occurs when the server response exceeds 100 seconds.

Error: Request failed with status code 524

   Failed to load resource: the server responded with a status of 524 ()

Error: Request failed with status code 524

I did research and they advised me to do the first procedure - it didn’t work.

  1. Page Rules
    I added my site
    Cache Level: Ignore

I did other research and subsequently did both and I still have this problem that is directly affecting the use of my application.
2. WAF
my site
Ignore

  1. Caching
    Cache Rules
    my site
    Ignore

I need to resolve this immediately. Which of the 3 should I use and what is the correct configuration to avoid error 524 after 100 seconds of returning my application. It’s a file upload that takes time to process on my server.
Note: I cannot use a subdomain in this case.

Cloudflare will time out if a response is not received from the origin server within 100 seconds. This time limit can only be increased for Enterprise plans.

You will need to modify your application to fit within the limit or not use the proxy.

Advice here.

Thank you very much for the quick response. I understood, but how do I remove a specific route from the proxy, i.e. mysite/up-file on the free plan?

You can’t, since the proxy works at the DNS level. You have to disable it for the apex domain or subdomain.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.