Error 522 Wordpress Wp-admin

Good night friends, I have a problem that is making me upset, I have a website in wordpress for 1 year and a half and I have received a 522 error for 1 week, but the funniest thing is that I get this error only when I am in wp-admin , when I navigate in my site normally as user it works without problems, but just to enter the page wp-admin begin the 522 errors, the funniest thing is that when I try again it comes without error, but sometimes it returns to display the error screen. … also realized that some functions such as putting the mouse on an option eg settings it does not show me a new tab with the options. my site is xpornass.com you can try to enter the link xpornass.com/wp-admin and check if you present such an error to you.
Already tried to do: disable plugins,
delete dns and put again in the cloudflare,
talk to locaweb where I host my website. I look forward to some help!

erro522|690x387

I’m getting error 522 only when I access the wp-admin from my site in WordPress, I wonder if I can disable cloudflare in that session

Since you have this problem only with wp-admin, my guess is you have some security tool (i.e. wordpress plugin) which is blocking Cloudflare IPs. Whitelist CF IPs in your security solution.

I would not recommend but since you asked, here you can find how to bypass CF for some URLs (*domain.com/wp-admin*).

I already disabled everyone plugin and the problem persisted what can it be?

Obter o Outlook para Android

Your website is proxied by CF and everything works except /wp-admin, yes? If that is true, your host is blocking CF IPs for that path, otherwise the rest of URLs should not work too. Since /wp-admin is the address for admin login, I guess there is some security mechanism that blocks CF (CF sends requests on behalf of clients through a few IPs of its own, triggering an IP rate limit on your side).

I would have to change hosting?

First make sure this is happening only when Cloudflare proxy is enabled (:orange:).
If so, ask your hosting if there is any security solution in place that blocks IPs which make too many requests to a specific URL. Share this thread with your hosting.

I left all values ​​with the gray cloud as in the photo, closed the browser, opened again and entered the site even though it presents the error 522, does it take a while to take effect or was it already to have stopped the 522 error? :grey:

Censoring the domain helps a lot in debugging :wink:

1 Like

/wp-admin properly redirects me to the login page.

Isnt that what is expected to happen?

1 Like

@gabrielpaulogomes, the domain itself should be enough for now. You can delete the posting with the two screenshots.

1 Like

@sandro the problem happens sometimes, if it does not happen on the login page, it happens at the time of authenticating the password or when I’m browsing through the wp’s actions … for example I tried to enter wp-admin now entered without error, when I updated the page error appeared :sob:

That would indicate that your server is not properly responding all the time but intermittently runs into a timeout, which subsequently makes Cloudflare display that error. I’d check that on the server, respectively with the host. Your host might even have configured some rate limiting.

2 Likes

This topic was automatically closed after 14 days. New replies are no longer allowed.